No Bluetooth signal, no service for BelanaSound

The first time I use it, I get the image file according to the deploy method, and then burn it to RPi4. After it is connected to the cloud normally, there is no service display, and no Bluetooth signal is found on the phone. What is the reason?

It’s already OK. However, from the log, it always prompts “Waiting for audioblock to start…”
What’s the reason?

Hi @matthuo, once your device shows up on the dashboard it will start downloading the services. You should see them downloading on the “Services” section in the dashboard.

Once all are downloaded it takes a few seconds/minutes for balenaSound to start up, “Waiting for audioblock to start…” is indicating the startup process is still ongoing.

Note that the message “Waiting for audioblock to start…” can show up even while some services are still downloading, so allow some time after all of them have downloaded.

By the way, for Spotify, can’t it be connected directly via Bluetooth? Through the Bluetooth audio receiving application of win10, I can use only Bluetooth.

Hi - spotify will need an internet connection on the device to play. If you play spotify from another device (e.g. phone) then you can send that audio to the balenaSound device via bluetooth, yes.

Is your balenaSound device now running correctly?

Also - could you let me know how you created the device, for my own understanding? Did you use hub.balena.io? If so, did you click the “Sounds good” button, or fork the app?

Thanks

Now it can run normally.
But I would like to ask, why does it have to be connected to the Internet to play music? I understand that the mobile phone can be connected to the device(RPi) via Bluetooth, and there is no need to use the network.

Hi @matthuo, once your device downloaded the balenaSound application and running it fine, the bluetooth audio should work without internet. Are you seeing any issues?

Now it seems that the device must be connected to the Internet before it can play music via Bluetooth.

Can you please explain your setup? Do I get it right that you have Windows 10 machine that broadcasts the audio via Bluetooth to the RPi4? Then do you get sound only when the RPi4 is connected to the internet?

Once you disconnect and the re-connect the RPi4 to internet, do you see any errors on the balenaCloud dashboard logs?

I see that couple of users asked about this connectivity requirement here and eventually they all realized the problem was something else: Using Balena-Sound without an Internet connection · Issue #86 · balenalabs/balena-sound · GitHub

So it help to understand your setup and what specific issue manifests on the device.

Through the issue of github, it seems to be disabled multi-room. But it didn’t work for me.
I connect to RPi via iphone bluetooth.
My installation process is based on your Guide, but it took a lot of time to install the BelanaSound application through the CLI.

The following prompt appears:

19.05.21 22:54:01 (+0800) multiroom-client 2021-05-19 14-54-01.118 [Error] (Controller) Error: Connection refused
19.05.21 22:54:01 (+0800) multiroom-client 2021-05-19 14-54-01.118 [Error] (Connection) Error in socket shutdown: Transport endpoint is not connected
19.05.21 22:54:02 (+0800) multiroom-client 2021-05-19 14-54-02.119 [Error] (Connection) Failed to connect to host ‘localhost’, error: Connection refused
19.05.21 22:54:02 (+0800) multiroom-client 2021-05-19 14-54-02.120 [Error] (Controller) Error: Connection refused
19.05.21 22:54:02 (+0800) multiroom-client 2021-05-19 14-54-02.120 [Error] (Connection) Error in socket shutdown: Transport endpoint is not connected
19.05.21 22:54:03 (+0800) multiroom-client 2021-05-19 14-54-03.121 [Error] (Connection) Failed to connect to host ‘localhost’, error: Connection refused
19.05.21 22:54:03 (+0800) multiroom-client 2021-05-19 14-54-03.121 [Error] (Controller) Error: Connection refused
19.05.21 22:54:03 (+0800) multiroom-client 2021-05-19 14-54-03.121 [Error] (Connection) Error in socket shutdown: Transport endpoint is not connected

In short, after many tests, the RPi must be connected to the Internet before the iphone can play music through Bluetooth.

Hi! Just to better understand the context could you let me know how you created the device? Did you use the “Sounds good” button or the “Fork this App” button on hub.balena.io? Or did you got balenaSound from somewhere else? Thanks!

I did not find the “Sounds good” button or the “Fork this App” button in following this Get Start (https://sound.balenalabs.io/docs/getting-started/).
Then, I installed the BelanaSound application through the following steps:

  • Install the balena CLI tools
  • Login with balena login
  • Download this project and from the project directory run balena push <appName> where <appName> is the name you gave your balenaCloud application in the first step.

Hi @matthuo. I think that my colleague was referring to this page balenaHub: an easier way to find and publish apps and projects for edge devices and was asking if you clicked the “Get started” of forked the repo.
The process you’ve followed is just fine. I’d like to ask you what is the Default device type you’ve chosen?
We suggest the Raspberry Pi (v1 / Zero / Zero W), even if you own a RPi4.
Could you please check and let me know. If you already moved with a different device type you’ll have to reflash your device and try once again.
You can also take a look at this list for common issues https://sound.balenalabs.io/docs/support

Let me know if you have any further questions.
Georgia

Thank you and your team for your support. Due to the recent work taking up a lot of time, there is no timely reply.
The device I use is RPi 4B.
Maybe there is a clue, I don’t know if it is related to this issue. RPi 4B has designed two versions of hardware. For V1.1 and V1.2,
I am currently using V1.1 version.

Thanks for getting back with the device type. Looking at earlier messages; am I correct in understanding that the connection to balenaSound works when you have the device connected to internet but not otherwise?

Also, the error which you shared in an earlier post were for multi-room. Are you using the multi-room feature? If not, let’s make a change and start simple without the multi-room support to see if the issue persists.

For removing the multi-room support you just need to remove the following two blocks, before executing a push:

Try the above, and let us know where we land.

Cheers

Yes, it does not work normally without the Internet.
I did not use it in multiple rooms. But I need to determine whether the currently running module includes multiroom-server, etc.
I will reply to you after I confirm it later.