No audio output from DAC

I have set-up BalenaSound with Raspberry PI 3B+ and Allo Boss Dac. I can hear from 3.5 mm jack of the Raspberry 3B+ but there is no sound when connected to the DAC.

DAC configuration

Log

Please help
Thanks,
Venkat

Hi

  • Just to confirm, is this something that you started seeing now? Did it work fine before?
  • Can you also ensure that you are running the latest version of balenaSound on your device?

@anujdeshpande,
It’s a new installation and I am using the latest version V2.80.3+rev1

@mybs, hi, I’ll need you to collect some logs to see what’s going on. Can you visit http://192.168.1.15/support (I’m assuming that’s the IP address of your device based on the screenshot you shared, be sure to double check) and share the output?

{“config”:{“mode”:“MULTI_ROOM”,“device”:{“ip”:“192.168.1.15”,“type”:“raspberrypi3-64”},“multiroom”:{“master”:“192.168.1.15”,“forced”:false},“audioBlock”:{"_events":{},"_eventsCount":2,“pulseCookie”:{“type”:“Buffer”,“data”:[0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0]},“connected”:true,“chunks”:,“requests”:,“lastRequestId”:14,“pulseAddress”:{“port”:4317,“host”:“192.168.1.15”},“address”:“tcp:192.168.1.15:4317”,“subToEvents”:true,“name”:“BalenaAudio”,“socket”:{“connecting”:false,"_hadError":false,"_parent":null,"_host":null,"_readableState":{“objectMode”:false,“highWaterMark”:16384,“buffer”:{“head”:null,“tail”:null,“length”:0},“length”:0,“pipes”:null,“pipesCount”:0,“flowing”:false,“ended”:false,“endEmitted”:false,“reading”:true,“sync”:false,“needReadable”:true,“emittedReadable”:false,“readableListening”:true,“resumeScheduled”:false,“emitClose”:false,“autoDestroy”:false,“destroyed”:false,“defaultEncoding”:“utf8”,“awaitDrainWriters”:null,“multiAwaitDrain”:false,“readingMore”:false,“decoder”:null,“encoding”:null},“readable”:true,"_events":{},"_eventsCount":4,"_writableState":{“objectMode”:false,“highWaterMark”:16384,“finalCalled”:false,“needDrain”:false,“ending”:false,“ended”:false,“finished”:false,“destroyed”:false,“decodeStrings”:false,“defaultEncoding”:“utf8”,“length”:0,“writing”:false,“corked”:0,“sync”:false,“bufferProcessing”:false,“writecb”:null,“writelen”:0,“afterWriteTickInfo”:null,“bufferedRequest”:null,“lastBufferedRequest”:null,“pendingcb”:0,“prefinished”:false,“errorEmitted”:false,“emitClose”:false,“autoDestroy”:false,“bufferedRequestCount”:0,“corkedRequestsFree”:{“next”:null,“entry”:null}},“writable”:true,“allowHalfOpen”:false,"_sockname":null,"_pendingData":null,"_pendingEncoding":"",“server”:null,"_server":null},“defaultSink”:“balena-sound.input”}},“audio”:{“name”:“pulseaudio”,“version”:“13.0”,“user”:“root”,“hostname”:“5642309255c1”,“sampleSpec”:{“format”:3,“channels”:2,“rate”:44100},“defaultSink”:“balena-sound.input”,“defaultSource”:“balena-sound.input.monitor”,“cookie”:2049500073,“channelMap”:{“channels”:2,“types”:[1,2]}},“sinks”:[{“index”:1,“name”:“balena-sound.input”,“description”:“Null Output”,“sampleSpec”:{“format”:3,“channels”:2,“rate”:44100},“channelMap”:{“channels”:2,“types”:[1,2]},“moduleIndex”:23,“channelVolumes”:{“channels”:2,“volumes”:[49152,49152]},“isMuted”:false,“monitorSourceIndex”:1,“monitorSourceName”:“balena-sound.input.monitor”,“latency”:“16967n”,“driverName”:“module-null-sink.c”,“flagsRaw”:162,“properties”:[[“device.description”,“Null Output”],[“device.class”,“abstract”],[“device.icon_name”,“audio-card”]],“configLatency”:“66666n”,“baseVolume”:65536,“state”:1,“volumeSteps”:65537,“cardIndex”:4294967295,“ports”:0,“activePortName”:"",“formats”:[{“encoding”:1,“properties”:}]},{“index”:2,“name”:“balena-sound.output”,“description”:“Null Output”,“sampleSpec”:{“format”:3,“channels”:2,“rate”:44100},“channelMap”:{“channels”:2,“types”:[1,2]},“moduleIndex”:24,“channelVolumes”:{“channels”:2,“volumes”:[65536,65536]},“isMuted”:false,“monitorSourceIndex”:2,“monitorSourceName”:“balena-sound.output.monitor”,“latency”:“0n”,“driverName”:“module-null-sink.c”,“flagsRaw”:162,“properties”:[[“device.description”,“Null Output”],[“device.class”,“abstract”],[“device.icon_name”,“audio-card”]],“configLatency”:“0n”,“baseVolume”:65536,“state”:2,“volumeSteps”:65537,“cardIndex”:4294967295,“ports”:0,“activePortName”:"",“formats”:[{“encoding”:1,“properties”:}]},{“index”:3,“name”:“snapcast”,“description”:“Null Output”,“sampleSpec”:{“format”:3,“channels”:2,“rate”:44100},“channelMap”:{“channels”:2,“types”:[1,2]},“moduleIndex”:25,“channelVolumes”:{“channels”:2,“volumes”:[65536,65536]},“isMuted”:false,“monitorSourceIndex”:3,“monitorSourceName”:“snapcast.monitor”,“latency”:“40035n”,“driverName”:“module-null-sink.c”,“flagsRaw”:162,“properties”:[[“device.description”,“Null Output”],[“device.class”,“abstract”],[“device.icon_name”,“audio-card”]],“configLatency”:“23219n”,“baseVolume”:65536,“state”:0,“volumeSteps”:65537,“cardIndex”:4294967295,“ports”:0,“activePortName”:"",“formats”:[{“encoding”:1,“properties”:}]}],“volume”:75,“constants”:{“debug”:false,“port”:80,“coteDelay”:5000,“mode”:“MULTI_ROOM”,“balenaDeviceType”:“raspberrypi3-64”,“multiroom”:{“forced”:false},“volume”:75}}

@tmigone, below logs also maybe useful in analyzing

Thanks,
Venkat

@tmigone,
Installed the lower version i.e. balenaOS 2.65.0+rev1 and checked, still the same issue. Checked the DAC separately and its working fine.
Thanks,
mybs

Can someone suggest some solution for this issue

Thanks,
MYBS

Hey @mybs, it looks like the system is not picking up your onboard audio card. Have you set audio=off on the device’s DT parameters? I ask because old guides for balenaSound used to ask users to do this but now it’s no longer required and can even break stuff (even if you are using a DAC like your case).

To be clear, you can view the DT parameters if you go to the “Device configuration” tab on the left side of the screen in your balenaCloud dashboard.

Hey @mybs! Hope all is well. Have you tried setting the DT parameter to audio=off yet? Please give this a try and let us know if it this puts you back on the right path.