New device download time is > 3 hours

I’m setting up new devices, it’s been downloading for the past 3 hours now, and still at 69%. Is this normal?

Download time will depend on the size of the image and the performance of the network. If the device has been stuck on 69% for a long time then that suggests that it may have hit a problem of some kind. If it’s a development image you could try ssh to it and see what is happening, otherwise it might be worth trying to restart the device and see if that helps.

I recently moved this application to another application. And now it’s stuck on download again.

Here is the screenshot.

I tried purging the data, doesn’t seem to help. And Terminal doesn’t work, keeps trying to reconnect ssh but can’t.

Please help

@mryangyu it looks like something strange happened when you moved the device because the resin-update.lock has not been cleared. You can try clicking “Enable Lock Override” from the actions tab on the device dashboard and see if that fixes things.

The terminal will only work once the device has a running user application.

If you are still having problems, please grant support access for 24 hours from the actions tab on the dashboard, post the device URL here and we can take a look.

I’ve tried that without success.

I’ve granted support access on the device.

Device url:

Sorry, I wasn’t clear. I mean the URL of the device dashboard e.g.


The device is offline atm. We’re taking apart out.

It’s back online again, same issue happening. something really weird is going on, perhaps 2 app is running on it at the same time?

edit: i checked our logs, there are definitely two apps running at the same time. it’s sending logs twice.

Hi @mryangyu,

I tried to jump into the device to investigate further but I still see it as offline.

Hi, I am colleague of mryangyu. Here is the link of the device.

Hi, would you please share your solution to this issue?
Thank you.