Device not downloading latest release


Hello, I pushed a change (14d6c19) to my application an hour ago but my device (cf766b6) shows no indication of downloading the change and remains on the previous release.

I’ve confirmed that my device is online (and I tried a device reboot) and tested that another device in a different application updates just fine on the same network. My device runs Resin OS 2.12.3+rev1 (prod) with Supervisor 7.1.14.

Is there a way to force the device (say, via the Host OS) to check for an update? Thanks in advance!

Device not updating to latest release

Hey, a device reboot should have had the supervisor check for an update when it came back, my expectation is that your device is probably experiencing an issue as I know that there are some in 2.12.3 which were fixed in 2.12.5 - if you grant support access I can check it out for you


Thanks a lot! I’ve granted support access. I’d love to help in any way that I can.


It looks like the problem was that there was a leftover migration lock in the supervisor that was causing it to fail to start, I’ve triggered a supervisor update for you to the latest released supervisor of v7.1.20 which includes a fix for this:

1 Like

Thank you very much.



I’ve got a similar problem, but on a newer version.
We have a device running 2.12.7rev1 (supervisor 7.4.3) which did not updated itself to the latest commit (other devices on the same application have).
Also, despite the fact service MAIN is running (the application itself is responding), I cannot restart or log into it over terminal, because the dashboard states the MAIN service is not running.
Login over terminal to the device is working fine.
Also, in the dashboard, there is a blue exclamation mark next to “Downloaded” on the main service.
I’ve granted support access to the device (will PM you the ID) if you would like to take a look.


hi, can you private message me with he dashboard link to this device please?


Just did. Let me know if you need something else.



has this device been renamed since it’s been provisioned?


It was only renamed once (from the default name that resin generates) to the current name.
That happened seconds after the device popped up on the dashboard for the first time.
No renames after that.


can we try to rename it to something without hyphens and then reboot the device?


Sure. You can keep the name, just drop the hyphens.
On the other hand, all of our devices have hyphens on their names and we never had a problem before. But you may go ahead if you think that will make a difference.

FYI: This specific device had a problem in the past (not occurring anymore), which is referenced here:


Hi @floion
Should we rename it, or will you do it?
Did you found anything else wrong? Device is still parked at the old commit.


Hi, we have found the problem and Cameron is working on it. You can see the progress here:


Excellent, thanks.
Is there any chance we can apply a workaround in order for the device to update, even without the patch?
Or should we wait so the fix can be tested?


I think it would be best to wait for a new supervisor release and then you can update the supervisor on your board.


We updated the supervisor on the aforementioned device and your device is now running the latest release of your application.
As a side note, could you remove the newline character from the device name?

Kind regards,


Hi @thgreasi
Actually, the device is down since yesterday. Did it came back up after the update?


Hi @ymaia ,
Yes the device did come up online and was sending logs properly. I monitored the device for about 15 minutes after the update and everything seemed fine.

The last connectivity event from the device was approximately 4 hours and 40 minutes after my previous response.
Any chance this is related with a network or power issue? Can someone check the device?


I experience a similar issue. Running development on balenaOS 2.31.5+rev1 and 9.11.3. But I do not understand why, since I have several devices running this configuration and they all seems to update seamlessly.
I tried rebooting the device and enable the lock override.
Moving the device to another application and back, but it seems that it keeps it’s release version no matter what application it is running on.
Usually I would just have flashed a new SD card but the device has been shipped to another city.

Extra: It seems that the ip is not the eth0 but something else.

I have access to the host OS, is there anything I can do to force the device to pull the newest release?