Never ending "Downloading image" .... Balena-cloud

During the past few days, I have tried multiple BalenaOS version with Raspberry pi4 to enable Airplay and Bluetooth. I was able to load the build properly (no error), but the problem occurs when the build is connected to the network.

As soon as I connect the pi to the network it tries to load the images and fails after some time. Here are the error logs -

09.09.20 12:13:23 (-0700) Failed to download image ‘’ due to '(HTTP code 404) no such image - no such image: No such image:
09.09.20 12:13:23 (-0700) Failed to download image ‘’ due to '(HTTP code 404) no such image - no such image: No such image:

I checked a few similar issues but not much help.

Network speed is pretty good (~100 mbps)
[balenaOS 2.47.0+rev1]

Any help on this would be appreciated. Apologies if it is a naive question :frowning:

Hi. What OS version are you trying? And can you share the uuid of the device please?

Thanks for your response.
OS version - [balenaOS 2.47.0+rev1]
UUID - 8e338a8a9590054fe03aac64f0d547c7

Granted support access for the next 12 hrs.

Thanks. Can you try to update the host OS to the latest version? 2.56.0+rev1

I have tried it with 2.56.0+rev1 version as well. I was getting the same error. But let me try updating it.

Starting the update now.

Getting error while updating to 2.56.0+rev1

resinhup failed: exit code null stderr: cat: write error: Read-only file system


Hi Alok,
I have tried accessing your device but it appears not to be accessible via ssh at the moment. If the device remains in this state and is physically accessible it might be worthwhile to reboot it and see if connectivity is restored…
Regards Thomas

Thomas - I just rebooted it. now I am able to ssh to it.

I am seeing some nasty messages in dmesg : mmc0: Timeout waiting for hardware interrupt. which indicate that there might be a severe problem with the SD card.
I would recommend replacing the SD card and then checking if these messages go away.

BTW - I have tried it with 2 different 16 GB (same manufacturer though) SD cards, got the same error. I have expected to receive another SD card on Friday. I will try with that and update the thread.

Thank you so much for your help!

If the error persists with different SD-cards it might be a different kind of hardware error.
Currently the device is clearly broken, I am getting I/O errors even calling ls -l

Okay @samothx . Let me try with another SD card.

While I am waiting for the new SD card …

I have found a thread where one of the solutions suggested was to modify docker-compose.yml file to load only one image at a time. I want to try this solution but I am not sure where is docker-compose.yml file location. Can you please help with this?

The docker-compose.yml file will be at the root of the directory that you push to balena.

Yeah I do see one here …

(base) C02LX7P3FD57:balena-sound-master alsharm$ pwd
(base) C02LX7P3FD57:balena-sound-master alsharm$
(base) C02LX7P3FD57:balena-sound-master alsharm$ ls -l docker-compose.yml
-rwxr-xr-x@ 1 alsharm ABCD Users 1447 Aug 24 12:09 docker-compose.yml

So I need to modify the file before pushing balena to the application? And if there are total of 6 images, I need push it 6 times to the application and only keep one uncommented?

I doubt though, that you are going to have much luck with the device in the state it is in now…

Okay so finally I was able to download all the images by restricting docker-compose.yml.

However, when I deployed the application, I used only an ethernet connection and did not choose wifi. Is there a way to enable wifi connection now after deploying the application?

Thanks! everyone for the help.

Hi, Yes it is possible but you will need to edit the SD card and enter your Wifi details. Insert the SD card into your computer open the resin-boot drive. From there go to system-connections and edit the resin-sample.ignore and then rename the file and remove the .ignore. Once thats complete return the SD card to your device and it will attempt to connect to WiFi. You can find more detailed instructions here:

Awesome! thank you so much. I was able to set it up.