MicroSD Not Showing as Option for Drive

Hi, I’m trying to flash the UmberOS onto a 128GB Samsung microSD. I’m using a Microsoft Surface Pro. The microSD is in the Surface and shows up as working properly under the Windows Device Manager. When I go to flash the SD in balenaEtcher program, it shows up as below (and is “hidden” initially, such that I have to click down to show it).

Hopefully the image shows up, but there is an error icon next to the device name and a red “System Drive” and blue “Source Drive” next to the location (C:).

Hello,
Thanks for reaching out. The red “System Drive” and blue “Source Drive” icons next to the location (C:) is the primary storage partition (C drive) on your Surface laptop. BalenaEtcher displays a warning here to inform users quite clearly to NOT use these drives for their flashing process as it would result in balenaEtcher flashing your C drive itself. However, regarding the SD card not showing can you confirm how much total storage is available on your surface laptop? (Is it 128 GB, 256 GB or 512 GB variant). Are you sure the drive that does show as hidden is your in fact the SD card that you wish to flash? Also, can you let us know what version of balenaEtcher you are using on (hopefully) Windows 10. Thanks.

Thanks so much for this response! Your explanation makes sense. The SD card I put in the Surface is 128 GB. My Surface is running on Windows 10 and has 119 GB total storage (20.9 GB free).

It’s strange, because the only Samsung device that balenaEtcher could be reading is this SD drive, and the descriptions match on the storage. I’m not sure why it’s referring to that as the C:\ drive. I tried uninstalling and reinstalling balenaEtcher, and removing and reinserting the SD drive at various times. In every one of those instances (even with the SD drive out), the same image showed up. So the description matches the Samsung SD, but it’s not being responsive in the program.

I’m using balenaEtcher-Portable-1.5.116

Hey Phil, I think that what etcher is showing there IS in fact your SSD, you can see that it reports its name as samsung-kus020203m-b000 which is a 128GB SSD disk produced by Samsung and included in your Surface Pro.
In fact, since it is still showing up when the SD card is removed it can not possibly be the SD card itself.
Do not flash this, as it will erase your drive!

It looks like etcher is not picking up your SD card, you mention that the SD card works correctly, so you see it appear in windows as a removable drive once it is inserted, is that correct?

Thank you! That’s exactly right, it shows up in the Windows device manager and is working properly in Windows, just not on the etcher app.

Strange, do you have any Security settings, Antivirus, or other user permission controls on the laptop that might be rpeventing Etcher from reading the SD Card? Do you have any other SD Cards you can possibly try, just to see if those appear?

Thank you, David! I am embarrassed to say that it wasn’t pushed in far enough. The SD card felt flimsy and I was hesitant to push too firmly. Thank you all for the help!

No problem, glad its now working!

Hello! I am actually having the EXACT same problem right now. My microSD is plugged all the way into my laptop (not loose at all) and it is still reading as hidden in balencaEtcher :frowning: I don’t believe I have any security/firewall settings that would be preventing etcher from reading it either.

Hey @stemgal99, can you provide your operating system and version of balenaEtcher? Does this microSD work in other computers?

Hey klutchell!

I am also using a microsoft Surface ironically haha. I’m using the v1.5.116 --portable x64 for Windows.

I even tried cleaning out the SD port on my laptop just to make sure I pushed in my SD all the way and there wasn’t like dust or dirt impeding it.

Is this a known working microSD card otherwise? Do you have any other computers you could try plugging it into? What is the brand and size of this microSD?

I’m using the samsung EVO select microSDHC. I’m currently on my college campus right now and all the computer labs are closed due to COVID and I only have one laptop/PC :frowning: Hopefully I can get it to work because this is my only hope

oh my goodness it just miraculously started working after I restarted my laptop… thank you so much for your time!!!

Let’s see what Windows thinks of that disk!

  1. Open cmd.exe from the list of installed applications, or from the “Run…” dialog usually accessible by pressing Ctrl+X. Type cmd.exe and press Enter.
  2. In the resulting terminal window, type diskpart.exe and press Enter. You’ll be asked to provide administrator permissions, and a new prompt window will appear.
  3. Run list disk to list the available drives.

Hopefully your card is showing here and isn’t damaged.

Could you also try pressing Ctrl-Shift-I after opening Etcher and browsing for drives? This will print some debug logs we can use to try and determine why Etcher isn’t seeing the drive.

I just saw you message that it started working so you can ignore my steps above! Glad to hear it and good luck on your project!!