Memory stick deleted files

When I flashed a Linux Mint image using Etcher ti , it deleted all the existing files on the memory card (which was priceless and there was enough space anyways) and did not install the image as well.

Right now all I see is a efi folder with bootx64.efi and grubx64.efi ?

What’s the best way to recover the files?

Killed my stick too in the same way. Software reported it had installed the Mint disk image just fine but in reality the stick only had this efi folder like you got and now the stick will only format to 2.2MB even though before this fiasco it was a perfectly working 128GB device. Don’t recommend anybody to use this software.

to burn a bootable image will inevitably need to wipe the whole memory card, so its our responsibility to backup the memory card or simply use an empty one
but you are right that it doesn’t burn the image correctly

1 Like

Agree - just wasted 2 hours trying to get this to work. It refuses.

Edit: just bought another drive a Best Buy. Same result, no bootable image.

Have you tried to delete and re-create a new empty GPT type partition table (DOS might work too) before formatting ? Maybe Etcher only formats partitions but not the partition table (that might be corrupted and that is why you may not be able to boot) fdisk is the tool you want to use for these operations.