Manifest Issue on push

Thanks to generous forum help, I have my raspberry-pi 4 set up on a windows 10 computer with balena-cli. I pushed the project, balena-cam, to my application/device. When I do so, I get this error:

manifest for balenalib/raspberrypi4-64-debian:stretch-20190612 not found

Thereafter, when I try to run the public url (I can boot the Raspberry PI and it shows as online on my dashboard), I get the following message:

tunneling socket could not be established: socket hang up

I have flashed the OS a couple of times on different cards to make sure that is not the issue.

Is it an RPI 4 issue? I could do the project with an extra RPI 3 I have? Or, am I doing something wrong.

Hey, the image balenalib/raspberrypi4-64-debian:stretch-20190612 does not exist, you can find a full list of the images here:

It may be enough for you to just use :stretch if you’re not worried about the exact build.

The socket hang up is strange, and implies there’s a network issue somewhere. Could you provide the dashboard url and enable support access please? I’ll see if anything jumps out at me.

So, I should flash one of the images from the url you gave me below rather rather the download I get when I set up the app/device?

I did enable support for a week.

As for dashboard url – is what I login to. But, I assume you are referring to something else? Do you need my login credentials?

John Gee

The images I linked to are for when you build with your Dockerfile, the balenaOS image should be the one that you download from the application page on your dashboard. For the link I’ll need the link to the device page, and you’ll need to enable support access with the dropdown menu next to Restart.

OMG, I just looked up dockerfile. I have read hours of documentation and had no idea. I was just following this simple web page:

There is nothing about a dockerfile in this. Thanks for your help, I will dig deeper into this.

John Gee

Thanks. I got Balena Cam up and running flawlessly on my RPI 3. Works well on Chrome and Firefox. Thanks for your help.

John Gee