balena deploy 400 error Image manifest data unavailable


I’m trying to use cli “balena deploy” to an open-balena instance and getting the error below.
I see a similar post points to no such image on dockerhub.
The image below is here:

I’ve tried other images, e.g. alpine, and with/without tags, all with the same error.

I did notice the ENOTFOUND message for my domain name. Not sure if that’s related to my issue. data.${domainname} wasn’t in the documentation, I don’t think. I created an A record for it anyway but still get the error, maybe it’s cached in my local machine.

jimbrockman@TH-JBROCKMAN app1 % balena fleets
Id App name Slug Device type Device count Online devices
── ──────── ──────────── ──────────── ──────────── ──────────────
1 jjbApp admin/jjbapp raspberrypi3 1 1

jimbrockman@TH-JBROCKMAN app1 % balena deploy jjbApp --debug
[debug] new argv=[/usr/local/lib/balena-cli/bin/node,/usr/local/lib/balena-cli/bin/run,deploy,jjbApp] length=4
[debug] Deprecation check: 0.16806 days since last npm registry query for next major version release date.
[debug] Will not query the registry again until at least 7 days have passed.
[debug] Event tracking error: getaddrinfo ENOTFOUND
[Debug] Parsing input…
[Debug] Loading project…
[Debug] Resolving project…
[Info] No “docker-compose.yml” file found at “/Users/jimbrockman/dev/balena/app1”
[Info] Creating default composition with source: “/Users/jimbrockman/dev/balena/app1”
[Debug] Creating project…
[Build] Building services…
[Build] main Preparing…
[Info] Building for armv7hf/raspberrypi3
[Debug] Found build tasks:
[Debug] main: build [.]
[Debug] Resolving services with [raspberrypi3|armv7hf]
[Debug] Found project types:
[Debug] main: Dockerfile.template
[Debug] Prepared tasks; building…
[Debug] main: Image manifest data unavailable for balenalib/raspberrypi3-debian-node:latest
[Build] Built 1 service in 0 seconds
[Error] Deploy failed
(HTTP code 400) unexpected -

Error: (HTTP code 400) unexpected -
at /usr/local/lib/balena-cli/node_modules/docker-modem/lib/modem.js:315:17
at IncomingMessage. (/usr/local/lib/balena-cli/node_modules/docker-modem/lib/modem.js:342:9)
at IncomingMessage.emit (node:events:525:35)
at IncomingMessage.emit (node:domain:489:12)
at endReadableNT (node:internal/streams/readable:1358:12)
at processTicksAndRejections (node:internal/process/task_queues:83:21)
From previous event:
at Builder.createBuildStream (/usr/local/lib/balena-cli/node_modules/@balena/compose/dist/build/builder.js:38:42)
at /usr/local/lib/balena-cli/node_modules/@balena/compose/dist/multibuild/build.js:94:21
at processTicksAndRejections (node:internal/process/task_queues:96:5)

For further help or support, visit:

jimbrockman@TH-JBROCKMAN app1 % cat Dockerfile.template
FROM balenalib/%%BALENA_MACHINE_NAME%%-debian-node:latest

CMD [ “balena-idle” ]

Flushed my DNS cache, the ENOTFOUND message is gone, but ultimately still get the same error “manifest data unavailable”

I worked around this by not trying to build the image within “balena deploy”.
I built the image outside of balena, then deployed straight from local image repo.