MAC OSX: The writer process ended unexpectedly.

I am trying to write a Rasberry PI image on SD card via BalenaEthcher and getting error i.e. The writer process ended unexpectedly.
I am using MacOS Catalina version 10.15.3.

Hi there!
Could you please provide us with some extra context:

  • The Etcher version you’re running.
  • Relevant logging output, if any, from DevTools, which you can open by pressing Ctrl+Shift+I or Cmd+Alt+I depending on your platform.
  • The type of the SD card you are trying to burn
  • Which Rasberry PI image are you trying to flash?

I also get this error, but simply making a second attempt works consistently.

My system:

  • macOS 10.15.4
  • balenaEtcher 1.5.86
  • 32G Samsung card

Sorry, I don’t have the card with me to give further information.

Hello, we’ve experienced people having with Catalina before. Have you tried running ether with sudo? This helped some other users.

Yes. Tried running with sudo, copied image in root balena directory and given 777 permission to img file. the problem persists.

Image: ubuntu-19.10.1-preinstalled-server-arm64+raspi3.img.xz
Balena version: 1.5.86
SD Card version: Kingston 32GB microSDHC Class 10 UHS-I
Error message: The writer process ended unexpectedly.

im haveing simeler issues tryignto burn ubuntu to a sandisk cruzer 16 Gb running 10.15.5

Hello, if you are still having issues its worth looking at the logs - could you open the DevTools with cmd + opt + i: it should open a new window where you can switch to the Console tab; there you’ll see a bunch of logs with timestamps and events, one of them should be the error that just happened.
If you don’t see anything valuable at a first glance, you can just copy whatever you see there and paste it here, thanks