Jetson TX-2 board with latest v2.9.7 resin not provisioning

Attempting to reprovision a Jetson TX-2 board with latest v2.9.7 resin. Was working with earlier resinOS.

Gone through all the steps of downloading and flashing to a quality 64Gb micro-sd card, then provisioning, leaving TX-2 to do its thing for over 30 minutes. Performed all these steps three times, but TX-2 just sits there with all its leds lit and nothing shows on my dashboard.

@PeterSprague What version of JetPack are you using?

?? Not using Jetpack to provision. Jetpack is for using on Linux PC to push updates etc to TX-2 last I checked. I’m failing to see the use case here.

Please enlighten me

So you had a version of resinOS flashed on the TX2 before you flashed the new 2.9.7 version, correct?


Was going to reflash today with Jetpack 3.2, which now has docker support and gpu access from containers. would at least get me back a useful TX2 for development

Is there any chance you could attach a serial cable to the device, just to get some data for this error?

I am very sorry you are experiencing this. I am actively trying to root this issue out, as you are not the only user to report an issue with our latest Jetson TX2 release.
If you could provide us with any data, it would help us a lot.

Kind regards,

Can do if can cobble the cabling together with old laptop. Need to see what I have around and will get back to you

Will wait on nuking resin from the board.

Note, I also tried an earlier release, but with same results

Mind providing or pointing me to a how to serial into the tx2 brd from Linux or BSD. Saves me a bunch of time trying to figure it out.

After looking at the brd, am I looking at usb serial?

Found this:

I dont have a usb to serial converter here, its at my other office. Will just use straight serial with null cable

Regarding the provisioning, are you using Ethernet or Wifi? If Wifi, would it be possible to try with Ethernet as well?

You mentioned that the device was flashed with resinOS before, what version was on this device before, that worked?

Was using ethernet.

Not sure on the version, I’ve blown away everything, applications, everything, think it was 2.3

Just wasted an hour trying to patch serial communications into tx2. Don’t have right cables and computer capable of serial at this location. Requires trip to elec supplies store for proper female to male jumpers, building new cable, and getting everything to communicate via an old workstation.

I’m nuking the board and install newest NVidia software with Jetpack 3.2

Thanks for the info, that is a very old version, that I think was reworked for the latest 2.7.x / 2.9.x releases. As far as I know, if there was a resinOS 2.7.x or newer on the device before, then it should work. Not sure if the same is true for version 2.3.0 (any thoughts, @telphan?)

The current guess is, that the device might have a too old bootloader that doesn’t let resinOS boot. If you flash the device once with Jetpack 3.1 or newer, afterwards I believe that it will be flashing correctly.

Plan is to nuke it anyway. Can try after. Was my thought

Sure thing, please keep us posted how it goes.

Reflashed tx2 with jetpack-3.1, then moved to jetpack-3.2.

The board is now provisioning with newest resin and shows in dashboard.

I had been using Jetpack-3.1 on the board prior to flashing with resin, so the boot loader should have not been to out of date.

This also opens the question of how do I handle customer’s units that may have been in the field for enough time to fail like this on an upgrade. Its one thing for me to reflash in a lab, quite another dealing with a remote customer with a non-functional field unit

Hi @PeterSprague, the field units will not have this issue, as host OS updates will always work with our own bootloader for all the releases since 2.7.x. ResinOS 2.3.x for the TX2 definitely counts as sort of a “pre-release” version for this device type.

Not sure if there were any other issues you hit earlier, since Jetpack 3.1 is known to work for provisioning (and Jetpack 3.2 is just release candidate, it’s not final yet). It’s good that things work now, and so far in as our testing goes, it should continue to work across versions.

If i’m reading right, all the NVidia JetPack install is replaced with resinOS, including bootloader on up?

Yes, that should be correct. The initial Jetpack install acts like a “reset”, when something goes wrong. Since after the resinOS install resin’s controlling the whole stack, we can keep it running. But for the first install, that needs a working system, and Jetpack’s the tool for that as the TX2 goes.