Trouble flashing Jetson TX2


So, i’m making a bootable sd card and then inserting it into the jetson, turning it off, and then back on to attempt to reprovision it, and nothing happens, it kinda just sits there with all the lights turned of forever… i’m kind of at a loss as to what’s going on? Is the flash memory on the Jetson corrupt?



Do you see the device pop up in your dashboard? If yes, what is the status of the device?
Kind regards,


Sorry for the SUPER delayed response, stuff has been busy. Unfortunately, nope the device never pops up on the dashboard


Also i should mention i’m trying to overwrite an old version of resin on the board already, if i take the SD card out it boots just fine to the OLD resin w/ the app running etc.


Would you mind hooking up a serial console to the device? I have never encounter such a behavior, I would need more data to be to give advice.


Errrr sorry i’m kindof a noobie at this, by serial console you mean taking a look at the output as it tries to boot? If so i’ve tried looking at the HDMI output but nothing shows up after i turn the power on. If not, could you elaborate a bit more?


Here’s an article on connecting a serial console to the TX2


Hi sometimes a fresh jetson is not be able to get resin os installed, what I usually do is flash the last jetpack and flashing the os only, and then using resin image afterwards.


Yes, for every TX2 that hasn’t been flashed with resinOS before, we would recommend flashing the latest Jetpack before attempting to flash resinOS. Many boards ship from the factory with old bootloader that is just not capable of a lot of things.


Hey all, so I just got the necessary cable and i’m going to give a look see as to what’s going on, curious thing is that the board DOES have a resin OS on it already, i’m trying to upgrade it essentially. I’ll post back once i get the console working etc


So i reflashed Jetson w/ Jetpack and then tried putting resin OS back on it andddddd WE’RE GOOD! thanks for the help guys!