Install Etcher on Mac


#1

Why do you computer enthusiasts always say how easy it is, and then make it utterly baffling to us ordinary folk?
Ubuntu says I should use Etcher to make a bootable USB, so I download Etcher, hoping for a .dmg file (they’re really easy) or a .pkg file (they’re fairly straightforward). But I get a .zip file. I double click and it expands to a unix executable file called “etcher-1.3.1-x86_64.AppImage”.
So how do install it?
I tried dragging it to a terminal window but all I got was " /Volumes/FAT/etcher-1.3.1-x86_64.AppImage -bash: /Volumes/FAT/etcher-1.3.1-x86_64.AppImage: cannot execute binary file". Then I opened it with a text editor and put all the gibberish into the terminal window. Still nothing.
So, can I ever hope to use Etcher, if so how, and if you’ve made it so simple why don’t you have either an installer that runs on the desktop or a step by step explanation?


#2

I downloaded Etcher again this morning. Clicked the same download button and off we went. This time it was a .dmg file! Excellent! And it opened! And it had a simple installer…which simply told me the current version of Etcher is incompatible with Mac OSX Lion. Why don’t you put system requirements anywhere on your website? Perhaps I could use Etcher CLI but there are no adequate instructions - what instructions there are, seem to presuppose a lot of CLI knowledge.


#3

Dude, do not install this shit. I installed, I was able to format a bootable drive to install openSUSE on my PC. Using the Mac.
Soon, the drive disappeared and you can not read on the Mac, I can no longer format or read.
I took it to the PC to boot and install, but on PC it tb is not read.
This seems more like a virus than a program. Destroy your drive and can not recover.


#4

We’re sorry you had a bad time using Etcher, but it’s nothing that cannot be fixed with a bit of knowledge :slight_smile:
First of all, @Baz I see you tried to install an AppImage on OSX, so I guess you didn’t choose the right file type from the website which for OSX is the .dmg, as you know. If the auto-selection doesn’t work, be sure to use the provided dropdown.
Secondly, if you’re looking for instructions on the CLI you can find them here, if you have any questions we’re happy to help of course but I’d suggest updating OSX first, if you can.
Last but not least, @uklima that sounds like a very common misconception: when you flash an image to a drive, it creates partitions that might not be readable to your host OS, so if you’re not sure about what to do with your newly flashed sd card/usb stick, you can find instructions on how to recover it here


#5

I must say I’m facing the same problems as others here seem to have: I downloaded an AppImage (the dropdown on https://www.balena.io/etcher/) is named “Download for MacOS” and you are only being offered AppImages. I don’t see any .DMG files available. I end up with this exec file which doesn’t seem to be executable in a Terminal window. My host is a MacBookPro running Mojave 10.14.1. Target is a USB drive I want to burn a Linux X64 to with the purpose to boot that Linux from my MacBook Pro to do some partition debugging/drive copying. Please tell me exactly the step I have to perform to get that done.

Christoph


#6

@Krischu Which browser and version of it are you using to browse the website? I tried with Chrome and Safari and couldn’t reproduce so far, while Firefox has a known issue on the dropdown button not working properly


#7

Hi,

I’m using Firefox 63.0.3 (64bit) under macOS Mojave 10.14.1.

The OS is determined correctly but clicking on the green button „Download for macOS“ results in nothing happening.

Since you are mentioning Chrome and Safari to be working for you I tried out Safari and this works.

So it must be as you are saying an issue with the button under FF.

Thanks. Solved at least with this workaround.