I/O error when flashing Umbrel on microSD using Ubuntu 18.04.5 LTS

I have a brand new Samsung 32GB microSD. When I run balenaEtcher on my Lenovo E540, Ubuntu 18.04.5 LTS, it sees the Umbrel image and the microSD.

When I try to flash, it always fails the same way; “Starting…” at 0%.

I went into the logs by pressing Cntl+Shift+i and found the error to be I/O related:

I’ve tried to find the answer online, but nothing’s worked. I’ve ordered a microSD-to-USB adapter to try instead since that’s worked for some people, so I’ll try that soon.

Has anyone had this issue or know what could be the problem?


Is your connection of SD card to the system secure/stable? The EIO with EUNPLUGGED is generally when we loose the drive (unplugged) in midst of flashing.

Also, can you test this out on another machine (if possible)? And do let us know the version of etcher you have in use here.

Yes it’s securely inside the micro SD slot. However, I’ve read others having this problem and solving it by either pushing it in as much as possible even after the click (didn’t work) or using a USB adapter (ordered one so I could try this).

I don’t have another machine that takes SD cards, so waiting on that USB adapter. The version of etcher is 1.5.116.

I was able to solve the issue by using a USB adapter. Once I plugged it in, my system detected the drive and I was able to successfully flash it with Umbrel. Cheers!

Sounds like you may have had a bad connection on your SD card socket. I’m glad that using a USB adapter has solved your issue.