How to set env variable in development mode

support

#1

I am developing an application locally, and pushing my changes to my raspberry 3 with:

sudo balena push <local_address> -s .

I try to specify an env variable in my .balena-sync.yml file, but this does not seem to work?

local_balenaos:
  app-name: local-app
  build-triggers:
    - Dockerfile: <docker-id>
    - package.json: <package-json-id>
  environment:
    - FOO=bar
destination: /usr/src/app
ignore:
  - .git
  - node_modules/

What syntax should I use for this to work?


#2

Hi @alexb,

What version of the balena cli are you using?

Also how do you check if setting the env variable worked?