balena.yml env vars not showing up in

Doing my first open fleet and can’t make my environment variables show up in newly provisioned devices. Fleet is bubblesnet3, and below is my balena.yml. I know the balena.yml is being seen, Ideas? Am I missing the purpose of that balena.yml section?

name: BubblesNet Edge-Device
type: sw.application
description: >-
  Deep-water-culture hydroponics ... automated
post-provisioning: >-
  BubblesNet Edge-Device is the measurement and control component of the BubblesNet system, a Raspberry Pi 3B+ based 
  device to measure the environment inside a cabinet/tent and through attached relay-controlled environmental control
  devices (heater, humidifier ...) to keep that environment in an ideal state to grow for whatever stage the crop 
  may be at.

  Thanks to Balena [OpenFleets](, you benefit from having automatic updates. As soon as updates are shipped, they will be deployed to your device.
    type: blob.asset
      url: ''
    type: blob.asset
      url: >-
    - BALENA_HOST_CONFIG_gpu_mem: 128
  defaultDeviceType: raspberry-pi
    - raspberrypi3
version: 0.1.1

How are you deploying the device? Are you using balena push or are you using the “Deploy” Button"?

The reason for asking is because the balena.yml file is used in this situation for the deploy with balena button.

For more information on the the deploy with balena feature, please refer to this document: Deploy with balena button - Balena Documentation

Tnx for the response. Balena push. Are you saying I can only flow through Env vars with the “deploy button”?

I REALLY REALLY want to do CD, not a manual button press.

Okay - I have deploy to balena buttons setup on two repos and both throw errors on brave and firefox (see below). Looking round the forums for clues. On Brave I get this error:

1.8912cb04e83a18f9efcc.js:2 Refused to connect to ‘edge-device/balena.yml at develop · bubblesnet/edge-device · GitHub’ because it violates the following Content Security Policy directive: “connect-src ‘self’ wss:// * wss:// * *”.

Starting a new topic because I’m down to one specific issue with configUrl.

the edge-device works correctly now if I’m logged in as the repo owner (not contributor) on github and as the owner on balena.

I am good-to-go with both repos. Thanks for the help. It was an issue with who I was logged into balena and github as when I hit the button.

@rodley Thank you for keeping this thread up to date as you worked through your issue, I just wanted to check that logging in as the repo owner solved the issue you were having?

If I explained ALL of the things I was doing wrong you might have to revoke my IoT-Guy Card.

I’m taking a system that runs in-house, built and deployed locally and making it public where it needs to build and deploy remotely via the deploy button. Bottom line, my builds were failing but when I built and deployed locally everything looked good. Basic misunderstanding of how this stuff works.