How to remove Balena from Rock Pi 4


Unfortunatelly I could not find any docs related to my issue, so I hope someone can help-me.

I would like to know how I can remove Balena OS from a Rock Pi 4, so I can run another OS from a sd-card.

I got an Rock Pi 4 which has no sd-card or Usb attached to it and when I start I just see a green Balena OS splash screen forever. By pressing ‘delete’ usb keyboard I can see a task running saying ‘start job is runnig … bluetooth firmware’. I tried to press a lot of buttons, but I couldn’t get to a terminal.

Thanks in advance.

Hello @fabriciovergal first of all, welcome to the balena community!

Could you please confirm what application are you running?

If you would like to run another OS on your Rock Pi feel free to flash another OS image on your SD card :slight_smile:

@mpous Thanks for the quick reply.

By now, I got this Rock Pi 4 from a random company which was going to dispose a lot of unused hardware and placed them for anyone to take.

I tried to flash a new OS and insert a sdcard but it’s never booted. It’s always end-up in this Balena slash screen. And as I said, in the original thread, I get this Balena splash even if there is no sd card inserted in the Rock Pi 4, so I guess it might be some custom firmware for belana cloud :thinking:

Edit: My bad, it’s a Rock Pi 4 instead RPi4

1 Like

Could you please confirm the exact model @fabriciovergal ? If that’s happening maybe it’s running some eMMC?

@mpous Thanks very much for you time. It was the eMMC all along.
Sorry for wasting your time :frowning:

No problem @fabriciovergal

If you would like to try balenaOS anytime just let us know :slight_smile: