How to fix my terrible mistake?

I backed up my entire Klipper install onto a 4TB (not 4 GB) Windows 11 USB drive. This worked OK. Now I want to restore the backup to a 32GB micro-SD card because it appears the latest Klipper update is buggy.

Apparently BalenaEtcher will only copy my backup to another 4TB device - of which I have none. It shows my backup drive as a “large drive”, so I’m guessing it will only do a restore to another 4TB device.

Is there a way to get my backup file off the 4GB drive and transfer it to a file on my PC so I can do a restore to the 32GB micro SD card? Are there any secrets about doing a restore from a good backup? Is there any reason BalenaEtcher does not have a Restore option?

Well I thought maybe I could use the 4TB USB drive as a backup for my Klipper micro-SD card if I made a separate 100GB partition on the 4TB drive. So I did that and then tried the backup again. But NOOOOOO…the latest version of BalenaEtcher recognized that there were 2 partitions on the drive, and even showed me their letter names. But it still wrote over the entire drive, making both partitions unusable in Windows.

Maybe development of BalenaEtcher has stopped? I find it hard to believe I’m the only person who has this issue with the software.

It’s been 8 days since you posted. Shows just how much of a cash grab it is.

I prefer to label it as unprofessional behavior. But - little difference I guess.