How do I utilize UPNP with Balena Sound?? I cannot find balenaSound on my UPNP app on ANY device

I’m getting very close to giving up, unsure what I’m doing wrong.

I’ve re-installed the OS numerous times thinking I’ve configured wrong, but doesn’t matter. I can get Spotify connect working, Airplay working but never UPNP. Bubbleupnp shows nothing for Balena, and I have my firewall checking for any UPNP on my network and it finds everything other than Balena Sound.

I’ve gone as far as to buy a new raspberry pi thinking it was a limitation of my RaspPi Model A, but nope the Pi 4 is just faster…

Do I need to enable UPNP somehow? Do I need to modify the configuration in some manner I’m unaware? I’ve searched and searched for an answer but there’s nothing regarding this issue anywhere.

To enable UPNP, you need to follow the CLI deploy method as listed on here Getting started - Home (balenalabs.io)

But before you do this step:

  • Download this project and from the project directory run balena push <appName> where <appName> is the name you gave your balenaCloud application in the first step.

You need to add the following to the sevices section on your docker-compose.yml file:

  upnp:
    build: ./plugins/upnp
    restart: on-failure
    network_mode: host
    ports:
      - 49494:49494

This is described here: Plugins - Home (balenalabs.io)

However, I have done this myself, and the balenasound UPNP shows up in windows 10, but i cant cast anything to it, and get the error “unexpected device error”. Ive also tried selecting the upnp device from other software and still get nothing. The logs in balena dashboard simply say nothing except that its started and ready…

upnp Starting UPnP plugin…
upnp Device name: Listen2This
upnp Using upnp UUID : b4786e058e861a35ad5f9231d83ee0dd
upnp gmediarender 0.0.7-git started [ gmediarender 0.0.7-git (libupnp-1.8.4; glib-2.58.1; gstreamer-1.14.4) ].
upnp Logging switched off. Enable with --logfile= (or --logfile=stdout for console)
upnp Ready for rendering.

Hoping that someone can shed some light on this.