Hangs at 84% While Flashing Linux ISO to Thumb Drive

Just bought a brand new thumb drive and tried flashing Garuda Linux ISO to it and it gets to “94% Validating…” and hangs forever. I brought up DevTools (CTRL+SHIFT+I) and everything is empty including the console. Please help.

Hi Patrick, welcome to the forums! Could you share some details about your setup? What version of etcher are you using? Which OS are you using? Thanks!

Hello, using the latest version (v1.5.113). Downloaded from the website two days ago. I’m using a brand new computer with Windows 10 also. And the thumb drive is brand new. I’ve seen some other posts in the forum on hang ups but no solutions. Is this an ongoing issue? Thanks for your reply.

Hi again, did you install etcher with the installer or are you using the portable exe?

We have had a few reports of etcher hanging, but nothing that seems repeatable and that can indicate a bug yet.

It is strange that you are not getting any console output though. Could you retry flashing the same thumbdrive having the console open at the beginning of the process to see if we can get any console output? Thanks again.

I installed Etcher with the installer.

Re-tried with DevTools open first. Didn’t see any errors however a noticed popped up. I will attach a screenshot.


And it stopped at 73% this time but again is hanging.

Forgot to attach the console log… -1608671712722.log (37.9 KB)

Also, now my laptop can even “see” the (empty) contents of the drive. Before trying to flash it recognized and would open the drive and show it was empty. Now it recognizes it but when I click on it to see the contents it says, “Insert a drive”. :thinking:

Hi Patrick, could you try flashing another image, such as gparted? https://gparted.org/download.php

This image is a good deal smaller, and I’m curious if it will write and validate.

Also, could you tell me what type of USB drive you’re using? Thanks!

gparted flashed successfully.

this is the drive i’m using…

ok, so i just tried flashing Garuda Linux to it for the 4th time… and it worked!!! happy, but why so many tries i wonder…

anyway ill let you know if i’m able to boot from it a little later.

thanks for all your help.

Merry Christmas! :christmas_tree:

it boots!

Hi Patrick,

Sometimes flash drives can be finicky, I’m glad you got it working!