Grub issue at boot of flashed iso

Hello all. I have Etcher successfully installed on Kubuntu 19.04.

I have also flashed the latest version of Manjaro Linux to my virgin USB stick.

When I reboot and boot from the USB all the screen shows is one word : Grub.

The fan goes crazy and I have to hard boot as no key stroke shows any reaction.

I have had the same result with netrunner-linux-rolling.iso

Does anyone have an idea of what is going on here?

Thanks for any help


Hi @fintanusa welcome to the forums! Do you see the same behaviour when flashing a different linux distribution, for example ubuntu? Can you try with a different USB stick and see if you have a different result

HI and thank you for that. I had already successsfuly flashed Kubunutu and debian based netrunner in the past and did it again today. So, that works. Does Etcher have issues with arch based distros? I also tried contacting on the Manjero and netrunner forums but no reaction at all for 4 weeks. Mmmmm…

@fintanusa no, Etcher only writes the disk image to the USB stick. If it works with dd it should work with Etcher.

Hi @fintanusa ,

As my colleague has said, if it works with dd (or another flashing application) it should definitely work with Etcher. Have you tried any other distributions or versions?

grub is a bootloader which is used to boot Linux for these distributions, and it sounds like there may be an issue with the written distributions.

Best regards,