Graphics device not properly supported by driver

Hi support,

I’m attempting to use my display via docker in Balena on an Intel Alder Lake and I’m experiencing issues accessing the graphics device. dmesg shows the following:
Your graphics device 4680 is not properly supported by the driver in this kernel version. To force driver probe anyway, use i915.force_probe=4680 module parameter or CONFIG_DRM_I915_FORCE_PROBE=4680 configuration option

I’ve tried adding i915.force_probe=4680 to the config.json and setting CONFIG_DRM_I915_FORCE_PROBE=4680 in the device setting but neither seems to have any effect.

Do you have any ideas on how to fix this?
Kind regards,
Josja

I’m not sure about the “not properly supported” part, but in the meantime I can help with the suggested workarounds. CONFIG_DRM_I915_FORCE_PROBE is a Linux kernel configuration item, so you’re probably only going to make use of that if you’re compiling your own kernel. The i915.force_probe=4680 however looks like a command line argument to the kernel. You can add them by editing the appropriate file. Depending on your setup, this will probably be /mnt/boot/cmdline.txt, or if that doesn’t exist, /mnt/boot/grub/grub.cfg, or if that doesn’t exist, /mnt/boot/EFI/BOOT/grub.cfg.

@hraftery according to this post: Setting kernel parameters in BalenaOS using /mnt/boot/EFI/BOOT/grub_extraenv changes to that file area not persistent over OS updates. Do you have any thoughts about that? Or is there any progress on making changes like that available from the dashboard?

Hi, as you mention balenaOS does not currently support customization kernel command line arguments. The recommended approach is for the user application to unload the graphics driver and reload it with the appropriate parameters before launching the graphical application.

The process would look something like:

  • stop plymouth with Dbus before graphics driver is used
  • possibly disable virtual console echo 0 > /sys/class/vtconsole/vtcon0/bind
  • rmmod {driver} / modprobe -r {driver}
  • modprobe {driver} … (new settings)

Check out the following forum post for a similar example blacklist drivers in host OS - #25 by jgordon.