Flashed to USB but then i they disapear off my desktop

First time i tried, i have flashed to a USB stick, it came completed, only problem is the USB is no longer showing up on my computer, i tried another USB stick and the same thing happened

Hi @Psicorman,

Welcome to the forums!

Just by your description so far, this sounds like you’re seeing the normal behavior from balenaEtcher, which is to eject the SD card after flashing the image. If you remove the card, wait a few seconds and re-insert it, you will be able to see some of the new partitions on the SD card. Windows cannot read some partition types, so you won’t see everything. It will show some partitions as unreadable, and some other spaces on the SD card will appear unallocated. This is all normal.



Its a USB, ive put it in but my computer does not recognise the USB device now as nothing comes up, when safely remove hardware, there is no selection of the USB. for all purposes i can no longer use it on the pc

Hi @Psicorman,

OK, let’s do some diagnostics and see whether the USB device has failed, or just has data on it that your computer can’t read properly.

First, we need to know a bit about your computer and the USB drive:
Is your computer running Windows, MacOS or Linux? And what version?
What kind of USB drive is it?
What image did you write to the USB drive?
What tool did you use to write the image (assuming balenaEtcher, but you didn’t say, so I want to be sure.)


Hi Mark,

Windows, 32GB KnowHow USB and 16GB kioxia,
tried both USB slots one of which is 3.0
yes used BalenaEtcher

Flashed a .img file and it worked and completed, i move it to my new rig and it shows, i bring it back to the main pc and nothing is registered even when i select the remove a drive nothing come up

Tried a space USB drive i had and that works so i know its ok, it just seems the USB i have used now my pc will not find them, what im going to do is reformat them on the 2nd pc and then try again

1 Like

Let us know what you find after reformatting the USB drives.