Firmware missing WiFi Card on Jetson Nano

I’ve connected a WiFi module via PCI-e ( Fdit Ar9280- Model:‎FLSM-DS02716-SNRMX-USWXR). It is detected as a wlan0, however, the MAC address don’t match with written at the sticker. If I run “nmcli d”, it appears disconnected and no WiFi networks appear by running “nmcli d wifi list”. Why the MAC address is different? any command to check that Nvidia Nano really is detecting the WiFi module?

This is the card info:

             description: Wireless interface
             product: AR928X Wireless Network Adapter (PCI-Express)
             vendor: Qualcomm Atheros
             physical id: 0
             bus info: pci@0000:01:00.0
             logical name: wlan0
             version: 01
             serial: b4:74:9f:b4:7e:96
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
             configuration: broadcast=yes driver=ath9k driverversion=4.9.201-tegra firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
             resources: irq:84 memory:13000000-1300ffff

The firmware appears N/A, which distribution is compatible with? debian? Please, find the output from dmesg. I cannot find wifi networks by iwlist wlan0 scanning, using iwconfig appears:

wlan0 IEEE 802.11 ESSID:off/any
Mode: Managed Access Point: Not-Associated Tx-Power:3dBm
Retry short limit: 7 RTS thr: off Fragment thr: off
Power Management: off

I’ve found this website with drivers, however, I don’t know which one is compatible. Any clue how make it work?

Hi, did you try to make this work with the Nvidia reference images first?

Hi, yes, I do have the version 4.9.201 and I’ve tried to install the firmware ath9k, Does the latest version of kernel include more wifi drivers?


Sorry could you please clarify

Hi, yes, I do have the version 4.9.201 and I’ve tried to install the firmware ath9k

Does this mean you’ve tried with another OS (not balenaOS) and the wifi-card works with that?

Thanks for confirming

Hi, I’m using the 4.9.201-tegra OS (i don’t know if that is the balena one). Find enclosed the hw information.
info.pdf (83.9 KB)

Hi @rparada. Thank you for indicating that you tried this with 4.9.201-tegra OS. I’m still a little confused about exactly which operating systems have been tried here. Question: How many different operating systems have you tried this with? Just one? Or more than one?

For each operating system that you have tried with with, on the device please run the command cat /etc/os-release and paste the results.

I’ve just tried with that one. Do you recommend me to use the latest one or should I try to compile a kernel with the drivers? I’m a bit lost here

Hi, have you tried downloading the latest Jetson Nano balenaOS version from this page: balenaOS - Run Docker containers on embedded IoT devices

No, I’ve just tried the “official” image from Nvidia. I’ve burned the “Nvidia Jetson Nano SD-CARD” into a 64 GB micro SDXC card formatting it to FAT32 then exFAT, and using Balena Etcher. However, when inserting the card into the sd card slot, the Nvidia logo screen keeps frozen.
Any idea how to solve this?

@rparada, there may be some confusion here. We don’t have anything to do with the images from Nvidia. You should probably contact Nvidia to see if they can help you. We provide an OS called BalenaOS and infrastructure that enable device fleet owners to manage and update their devices. Your question is not in relation to any of our products.