File size is greater than possible Buffer: 0x7fffffff bytes


#1

Hi I’m trying out balena for the first time, by trying out the Web Frame:
https://www.balena.io/blog/make-a-web-frame-with-raspberry-pi-in-30-minutes

All good until I run the command balena push myapp

I get the following error on the terminal:
Packaging the project source...File size is greater than possible Buffer: 0x7fffffff bytes

and exits without the unicorn.

My laptop is running Ubuntu 16.04

Any ideas what’s going on?

Thanks!


#2

Hi @pschalkx,

following error message …

… means that the balena is trying to package your source folder and the resulting file is bigger than 2.147GB (roughly). Can you please check what’s the size of your source folder? Thanks.


#3

Hi zrzka,

Apologies for not replying before, had a very busy week.

Anyway, the source file is the Balena-dash-master from Github (https://github.com/balena-io-projects/balena-dash). Onze unzipped the directory is only 7KB.

I don’t have experience with dockerfiles, but 7KB sounds suspiciously small…

Rgds

Philip


#4

Hi @pschalkx,

I’m trying to reproduce it without success. Can you please share:

  • exact steps what have you tried?
  • can you paste here the whole output of the balena push ... command?
  • can you run the balena push ... command with the DEBUG=1? Like DEBUG=1 balena push ...

Thanks!


#5

Hi zrzka,

I just ran the push command with the debug=1 option, it gives just a bit more info:

xxx:~/Raspberry$ DEBUG=1 balena push WebFramePiZeroW
[debug] Using . as build source
/ Packaging the project source…RangeError: File size is greater than possible Buffer: 0x7fffffff bytes
at FSReqWrap.readFileAfterStat [as oncomplete] (fs.js:453:11)

As for the steps I tried are the ones on the balena website:

https://www.balena.io/blog/make-a-web-frame-with-raspberry-pi-in-30-minutes/

I got stuck in the section “Pushing your project code to your Raspberry Pi”

I’m running Ubuntu 18.04

Hope this sheds a bit of light on this issue.

Thanks.

Philip


#6

Hi zrzka,

I took another Linux machine and followed all the steps on the balena page to build the webframe. This time I had a bit more success, but aren’t there yet.

I got to push the app via the CLI and got the unicorn on my PC scree, the filesize matches what is shown your website.
However, the app is not deployed to my pi + screen. The pi+screen appears as online on my dashboard, so far so good. But the pi screen just shows “balena os, Booted check your balenacloud dashboard”.

So, I’m at a total loss here. Can you give some hints?

Thanks!

Philip


#7

For the file size: It looks like you are trying to push all of your ~/Raspberry directory rather than just the source to the project. Push takes the remote application name as the argument.

For the second problem: Is the Pi joined to the right application?

What do ‘balena apps’ and balena devices’ say?