Etcher stuck on "Starting"

Hi. I’m using Etcher 1.5.19. I’m able to select my image and the drive, but when I press “Flash”, the button changes to “Starting” and does nothing else. My spidey sense tells me it might be waiting for admin permissions, but they are never requested. Does anyone know what’s going on?

Thanks in advance.

1 Like

Hey @emarthinsen welcome to the forums. Your spidey sense is probably correct on this! What platform are you running on? If Windows you could right click on the app and launch it with admin permissions and see what happens.

Doh, I forgot to mention that crucial piece of information. I’m running Ubuntu 18.04.

@emarthinsen do you see anything in the logs (ctrl +shift +i then go to the ‘console’ tab)?
You may be able to work around that by running etcher with sudo balena-etcher-electron.

I’m also having the same issue but on Windows 10. I have tried to run it as admin but with the same result.

Here are the logs:
1554837898633.log (8.3 KB)

Hi @etricky , welcome to the balena forums.
There has been an issue with supervisor rights but it was fixed a while ago.
I will have to talk to the etcher team to see what might cause your problem…

@samothx Just to let you know that I installed an older version, 1.5.18, and I’m able to use Etcher just fine.

It was never fixed. Even when the changelog said it was fixed, it still hung… except back then there was the CLI that always worked reliably. Now that you’ve removed the CLI, I’m back to fighting “Starting”.

I have a similar problem. I read a post which said that using version 1.2 solved that users problem and I’m trying to find it again and also how to download version 1.2.

hey @yorgg75, I see that you posted a follow-up to this on My Etcher claims 1.5.5, hope the latest Etcher version will fix your issue, and let’s continue the discussion there, probably. Thanks!