Etcher lost access to the drive

I started seeing an issue with the new Etcher update 1.5.116. I use .sdcard files (same procedure for years) and use Etcher on Windows 10. I started getting this error when I go to flash:

Looks like Etcher lost access to the drive. Did it get unplugged accidentally?

Sometimes this error is caused by faulty readers that don’t provide stable access to the drive.

I tried:

  • SD card reader on my PC
  • USB to SD card reader
  • My coworkers PC running Windows 10

But on a Window 7 PC with Etcher 1.5.70 works perfectly. Seems to be tied to the Etcher update. Any ideas?

Hi @speterson,

Welcome to the forums and thank for your message!

Could you try flashing the SD card again using the same procedure on Etcher 1.5.116 and share the console log output?

You can get the console logs using Ctrl+I or through the View menu > Toggle developer tools and then clicking on the console tab.

This might give us some extra debugging information which might help us pinpoint the issue


I attached two logs. In both cases this was run on Windows 10 with Etcher 1.5.116 with the same .sdcard file and SD card. The variable is where the .sdcard file was located.

One was with a network mapped location (longer file path) and the other I copied the .sdcard file to my Desktop. When I copied the .sdcard file to my desktop - it worked.

fail-overnetwork.log (3.6 KB)
pass_desktop.log (3.7 KB)

Hi again,

Thanks for sharing the logs. The fact that flashing fails for the network mapped file might be relevant here. For your tests with Etcher v1.5.70, were you also using the same network location?

Where is the file server located? Is it on your same network? How are you connecting to the network? Through ethernet or wifi?

Sorry about the flood of questions, but getting the context right might help us replicate this issue.

Thanks again!

For the tests with Etcher v1.5.70 - yes I was able to use the same network location.

The network mapped fileserver is on the same network and using Ethernet.

Hi, can you verify if the 1.5.70 release works on your Windows 10 computer?

That way we can verify if the problem is with Windows 10 specifically or if there was a change made in the etcher sdk that caused the issue.

If that version works, it would be really helpful if you could let us know the latest release where etcher can still flash the network mapped file server.

Could you also tell me a little about this file server? According to the error, the drive was unplugged, but it doesn’t sound like that’s the case. Is there any reason for that specific to your setup you might be able to think of?

I’m having this same issue on both windows 10 and windows 11 for an image on a locally network mapped filesystem on a gigabit LAN. I’m using version 1.71.

I have the same issue. If the source is located on a mapped network drive in Windows 10, I receive the same error. I’m using an Ubuntu ISO. Once I move the ISO to a local drive, it works fine.

So, apparently this is a known issue: Unable to open an image from the mapped network drive · Issue #2858 · balena-io/etcher · GitHub

We are currently working on a new implementation that will be able to handle issues like this.

1 Like