Etcher 1.5.64 not writing to SD card

I’m trying to update a version of PiCore player on an SD card that was originally flashed with an earlier version of Etcher ( which worked perfectly) but I have now tried two SD cards and though after going through the process and Etcher claiming success when I check the card it hasn’t been updated… to confirm this I cleared all the content from one card (in finder) and tried again… nothing was written to the card. I did notice that though the card is 16GB the partition that I’m seeing in finder is only around 64MB… but this was where the previous PiCore install was… so not sure what is going on?

Grateful for any help


Etcher obviously flashes whatever image is passed to it onto the media, so if this is comprised of a small install ext3/4/FAT32 filing system, for example, then that may well be why the partition is only 64MB once written.

It sounds like maybe the image being flashed may be corrupt? Could you point us at the image you’re trying to flash, and we also try this to ensure it’s behaving as it should?

Best regards,


Also, could you let us know which host OS you’re using Etcher on?

Best regards,


Thank you for the reply. Here is the PiCore download link :

I tried both 26 May 2019 downloads.

Running Etcher on both osx Sierra and ElCap

Hello @anotbot,

Unfortunately we don’t have a device running Sierra or ElCapitane to test. We tried download the same image and flashed it on an SD on macOS mojave. We also deleted the contents from finder and cleared the trash and proceeded to flash the card again. The flash was successful and the contents of the image was written as intended.

As for the small size of the partitions, the image creates two partitions as follows:

   #:                       TYPE NAME                          SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *4.0 GB     disk2
   1:     Windows_FAT_32 PCP_BOOT             33.6 MB    disk2s1
   2:      Linux                                                        50.3 MB    disk2s2

This is expected since the piCore player is designed to have a small footprint.

If you are still unable to flash the image, maybe you can try to erase the card as per this guide and try to flash the image again?

Let us know how this works for you

I went back to my old version of Etcher and it worked fine… seems to be a problem with your update and Elcap and Sierra.

Thank you for the help