Error with password prompt on mac

Quick thing I just debugged w/ balenaEtcher, saving here.

I was running into an issue when flashing an ubuntu CD image to a USB thumb drive, and the step where it asked for a password would just happen over and over and over again.

I’m pretty confident that the password was correct and found other suggestions on this forum to check “sudo su -”.

When I did that on the terminal, it asked for a PIN instead of a password.

I have a hardware security module attached to my machine sometimes, and it’s setup such that I can use HSM + PIN for authentication instead of admin password for things like sudo.

I restarted balenaEtcher and tried again and when it asked for a password I instead entered a PIN – and it worked!

It would be useful if in those cases balenaEtcher changed the prompt in these cases to ask for a PIN instead.

Let me know if there’s a different place that I should file this as an issue or bug report. Thanks!

Nice find @machinaut , hopefully it helps folks who might stumble upon this. Of course PR’s are always welcome, but even so we’ve passed it along to the Etcher team to have a look. Thanks for documenting it!