Etcher asks for a password on my MAC, does not recognize my admin password

Hello. Just loaded Etcher for first time and found that Etcher keeps asking for a password when I try to finalize the transfer process of a file to a flash drive on my MacbookPro. Apparently, it is not the my/administrator’s password, because the window reappears after I enter the password. (Please note I am not a techie, so pls keep that in mind when explaining any how-to instructions). Your assistance is much appreciated…I read through this forum and tried things I read, as best as I could understand the processing.

When I enter the password, a window displays “You are not authorized to perform this function”.

I copied/pasted the “sudo…” app in my Terminal as was suggested and it asks for a password. I entered my admin password but still no-go.

That’s strange!

  • Can you let us know where you downloaded Etcher from?
  • What version of Etcher are you using?
  • What version of Mac OS are you using?

I know, right ?!?! But I read other MAC users had same/similar issues. I downloaded from GitHub on the Internet. Originally I had 1.2.0, but then tried the 1.5.115 version when asked to get new version. I’m using Big Sur version 11.1

Hi there, if you open macOS Terminal app and type in sudo su -, the password you should be prompted for is your user password, the same one you use to login when you start you computer. If this doesn’t work, then the mac’s software configuration needs to be checked. It may be best to open a case with Apple support and have them guide you through fixing it.

If however, $ sudo su - returns a prompt (after entering the password, or not) - this prompt should start with # , meaning root access.

At this stage you could start Etcher by running: /Applications/balenaEtcher.app/Contents/MacOS/balenaEtcher. This Etcher instance will run with full system privileges and shouldn’t prompt you for a password.

Hello. I tried the ‘sudo’ deal before, but did it wrong I guess…(not very computer-savvy, lol). I inferred, from a forum, that I had to include “sudo” when I pasted the application in Terminal, because that was highlighted as the first part of the “Application/…” copy/paste text in the forum. I note that is not the case in your email.

I very much appreciate your response, thank you.

Have a blessed night!

Rob

Glad we could help!