Error msg from BalenaOS re BalenaSound on R Pi Zero W

Pretty dadgum noob status - trying to run BalenaSound on R Pi Zero W.

Using factory build release, OS version 2.48.0 +rev.1, after the Balena cube image I get ascii art splash from BalenaOS with the following error message (not the expected Services running notifications):

Booted - Check your balenaCloud dashboard.

Prior to this error message, I see about a dozen lines including " … wlan0 - the link is not ready."

Reading project instructions, I’m supposed to check my network settings; those are confirmed to be right so far as I can tell (I use the same info on same device running Raspbian and works fine).

So I’ve tried running Health Checks and Diagnostics from the dashboard.

Health Checks all green succeeded.

After running Diagnostics, the message from balenaOS changes to:

**ICMPv6: process ‘sysctl’ is using deprecated systctl (syscall) net.ipv6.neigh.balena0.base_reachable_time **
use net.ipv6.neigh.balena0.base_reachable_time_ms instead

I know just enough to believe I should replace the deprecated-verbiage with the instead-verbiage, but I don’t know where I should find which text file to do that with. If I am even granted permission as user to do so. And presuming I’m right in that assumption…

So I go back to dashboard, scan the Standard Error output for reference to sysctl and find this section:

— sysctl -a —

sysctl: error reading key ‘net.ipv6.conf.all.stable_secret’: Input/output error
sysctl: error reading key ‘net.ipv6.conf.balena0.stable_secret’: Input/output error
sysctl: error reading key ‘net.ipv6.conf.br-35be63a17e58.stable_secret’: Input/output error
sysctl: error reading key ‘net.ipv6.conf.default.stable_secret’: Input/output error
sysctl: error reading key ‘net.ipv6.conf.lo.stable_secret’: Input/output error
sysctl: error reading key ‘net.ipv6.conf.resin-dns.stable_secret’: Input/output error
sysctl: error reading key ‘net.ipv6.conf.supervisor0.stable_secret’: Input/output error
sysctl: error reading key ‘net.ipv6.conf.wlan0.stable_secret’: Input/output error

— systemctl list-units --failed --no-pager —

So… now I am feeling confident that sysctl needs editing, but I’m stuck. Where? How? In a config file? Can’t find any such command in config.txt. Am I overlooking something?

I’m willing to read more instructions or search more forums, but I’ve exhausted what I know about and what I can find.

Can someone point me in a noob-friendly (or at least noob-tolerant) direction?

If it helps, I’ve granted support access through my dashboard.

Appreciation in advance.

Hi, are you modifying BalenaSound in any way? There should not be any need for sysctl editing for this project if you did not modify it.

Thanks for responding, Floion.

No, I haven’t modified BalenaSound in any way, not that I know of. (I can only guess at how I would.)

It’s a mystery to me why running the Diagnostics should elicit the error message about using deprecated systcl.

Would it be possible for you to try with a different SD card and provision balenaOS on it and try this process again?

Yep, will do.

New device - Sandisk Ultra UHS-1 card, 16GB, A1 Speed upo to 98 MB/s 653x, brand new.

‘weathered leaf’

Same results: Check your balenaCloud dashboard. (No LED flashing, neither 4 nor 7.)

Health check: all green

Diagnostics: ICMPv6: process ‘sysctl’ is using deprecated sysctl (syscall) net.ipv6.neigh.balena0.base_reachable_time - use net.ipb6.neigh.balena0.base_reachable_time_ms instead

Have granted support access to this device as well.

Eagerly awaiting suggestions for a next step, thanks!

Hey there @mrphd

I’m reading this thread and finding it hard to understand what part of the project isn’t working, could you clarify, ignoring any error messages, what is not working? What problem are we trying to solve? Have you tried searching for the bluetooth/Airplay/Spotify device and connecting to it with a phone or another computer? Do you see the device and does it connect?

It looks like you’ve got a monitor plugged into the Pi - what are you using that for? Most balenaSound users never plug in a monitor, but if you’re trying to play audio through a TV over HDMI that’s a valid use case although the TV will never show anything other than what you’re describing. If you’re not using a TV or monitor for audio, what DAC are you using?

Are the services in the dashboard running OK? It may help if you share a screenshot of the device page here, too.

I’m sorry there are quite a few questions there :sweat_smile: if you can help us with a bit more information we should be able to give some more suggestions.

Hi Chris, thanks for responding!

Apologies for being unclear about the problem; will try to shed some more light, here.

  1. When I boot my Pi, my dashboard never indicates that any services are running. I can run Health Check and Diagnostics from there, and generate logs, and Diagnostics generates a message to my Pi about ‘sysctl’, but I never get the listing of services running that project instructions indicate I should.

  2. Nor do I get any patterns of flashing leds on my Pi.

  3. Nor can I find any indication of a bluetooth device when I scan for such (though I am not sure what label/name I should be looking for).

  4. I’ve got an hdmi monitor hooked up to my Pi with a splitter to get the audio output for testing. I plan to use a Phat Dac yet to be assembled as soon as I know that I’m booting up successfully.

  5. Because I can get … um, dialogue?.. from the dashboard, I assume I’m connected to the balena VPN, but I’m not sure that’s correct. I don’t know what other connection(s) might be relevant.

Here’s a screenshot of my device:

Hi, please share the full uuid of the device and enable support access on the device so we can try and debug remotely

Thanks, Floion:

UUID: b765bfe30981dfa1190a16dc75d5ddbe

Support access enabled.

Hi, the problem with your device is that you have not pushed the balenaSound project to your app. Please see here on the available methods that allow you to push the project to your device: https://www.balena.io/docs/learn/deploy/deployment/

Thanks, Floion - that sounds logical, except that I didn’t see anything in the project instructions about pushing the BSound project to my app.

I presumed (incorrectly, I now understand) the “Create and Deploy” directions from the project instructions to do all the required setting up and configurating.

Looking at the methods you referred me to got me thinking that I needed to learn a bunch more than the project directions had indicated to me… Noob bows head and sighs at his own ignorance…

Re-reading more, I found in the project directions the statement that once the properly configured SD booted up, it should begin downloading the balenaSound project to the card - and begin running the services listed on the dashboard. I’d never seen any indication that either of those things had happened on any of my four prior trials.

So I started from scratch, again!, doing things just as I had done before, and lo and behold, this time everything worked like it was supposed to!

The newly created SD booted up, showed up on my dashboard, and this time, began the progress bar indicating that it was updating (without my making that happen in any way I know about), and then listed all the running services! Ta-dah.

And sure enough, scanning for the device on bluetooth showed a balena option, successfully connected.

Now, on to building the Phat DAC and getting sound.

So many thanks to Chris and Floion for their assistance, for real.

And for those following this thread, consider it solved … by doing the same thing I had done before for the fifth time on the third SD card.

I’m pumped!

Hey, glad you could get it running! Let us know if you need any help with your future projects :slight_smile: