Balena Sound on Pi Zero W Services Not Showing Up

I’m setting up the Balena Sound system on a Raspberry Pi Zero W. I Got everything set up to step three here. Then I booted up the Pi, let it connect under the device tab, then under the services tab, nothing the services aren’t downloading or setting up?

On the BalenaOS Screen I get the following:

Booted - Check your balenaCloud dashboard.
IPv6: ADDRCONF(NETDEV_UP): supervisor0: link is not ready
IPv6: ADDRCONF(NETDEV_UP): br-dafc808559bg: link is not ready

Can anyone help? Guide me in this a little, am I missing something?
Thanks for the help, guys!

Just to add, there are no issues appearing in the logs.

From what I understand the device should indeed start downloading the app at that point. These IPv6 messages shouldn’t affect anything. You can get more insight into what’s happening by SSH’ing nito the host OS via the balena Dashboard terminal and checking the logs with journalctl -fn100.

Thanks, I’ve started from scratch again and now have a different issue ;-( But I’m wondering if because it’s a Pi Zero the download is slow, I’ve found when working on the Zero’s they can be quite slow.

Once I get over my current issue, if I hit this problem again I’ll SSH into it and see what happens.

If it’s the download that’s causing issues, pushing to the device in local mode might help in debugging network issues. You can also ssh into the the device through local mode for better ssh speed.

So I switched out the Zero and put in a spare Pi 3 and now it’s stopped at Supervisor starting.

I tried what you suggested and there was a long list, Error was

error: Could not load host key: /etc/ssh/hostkeys/ssh_host_dsa_key

If I restart the pi, does it need to be reformatted before since it hasn’t connected the services? or can I just simply restart it in Local mode

Hello, could you clarify what you did exactly when switching to the RPi 3. Did you flash an SD card with a new balenaOS for Raspberry Pi 3 and then insert that into the new device ?

Hi 20k-ultra,
Ya, I flashed the SD card for a Pi 3. But I’ve switched back and I’m pretty much at the same point. I just SSH’d into the app and I ran the command

journalctl -fn100

with no errors. Any suggestions would greatly be appreciated!

Where I am at this moment is, back on the Pi Zero, I’ve run everything and I’m currently at:

IPv6: ADDRCONF(NETDEV_UP): supervisor0: link is not ready
IPv6: ADDRCONF(NETDEV_UP): br-9494d1ff7f78: Link is not ready

I’ve run journalctl -fn100 and so for (it’s still running) no errors.

Thanks for the help guys.

It sounds like the Supervisor isn’t starting as you mentioned before which would prevent the services from starting because nothing has told the device to pull them. When you watch the logs is the last message “Supervisor starting” like before? Check out Run those diagnostics and see if you find anything that could be causing any issues. Attach your logs in a response if you’d like as well.

Thanks 20k-Ultra, attached are the two images so far of the command I ran and here’s the log from inside the system.

(Sorry I have to place the logs in separately because I’m a new user and only allowed one image at a time.

I’m running the diagnostics now, I’ll update shortly.

Just to update things, I’m back on the Pi3 and I’ve tried directly plugging into the ethernet and got the same issue.

Here’s the Diagnostics.

Doing some research, I found this Balena Sound page. At the bottom, it says I have to deploy the software to the Pi.

On the original document, I was following; it mentions that it will automatically download.

Should I deploy/push the software using the terminal in Balena Cloud?

Just checking in to see if anyone has a suggestion on the Deploy application question? I tried deploying with Balena CLI and I’m getting this error.

Error: no “Dockerfile[.*]”, “docker-compose.yml” or “package.json” file found in source folder “.”

Regarding your question about deploying the application using CLI, you should follow these steps

  1. Go to balena dashboard and create a new application and download balenaOS image for your device (PI3 for example)
  2. Flash the image to your SD card using Etcher, Power up the Pi and check it’s online in the dashboard
  3. Download the application from Github
  4. Go to the directory of the application
  5. Push the application using balena push YOUR-APPLICATION-NAME , you will replace “YOUR-APPLICATION-NAME” it should be “balena-sound” in your case.

If you want to use “Deploy with balena” button, It will make the 1st step for you.

Please take a look at the getting started page, it is very helpful.

Hey guys,
Unfortunately, I had to abandon this and went with Shairport-Sync on Github. It just worked. I plan to come back to this and try to get this working for the multi-room, but I needed it up for a family gathering.
Thanks for the help!