balenaEngine on Raspberry Pi Zero Segmenation Fault

Dear all,

I tried to use the latest versions of balenaEngine on a plain Yocto Warrior Image built for MACHINE = “raspberrypi0-wifi”, however, I always get a segmentation fault or similar error, no matter which version I try from the github ( https://github.com/balena-os/balena-engine/releases/tag/v18.9.7 ) arm releases. Any special magic needed here? :slight_smile:

Best regards,

Nico

Can you post some of the stack trace here? I would be mostly interested in the first few blocks of it

I will try to do so. As a short question: As the RPi Zero W has an ARMv6l processor, I would need to use the ARMv6 version of balenaEngine, correct? :slight_smile:

Hi @robertgzr,

I just found an old Raspberry Pi 1 and tested it with a Yocto / Poky (Warrior) release.
./balena-engine
just results in the Output of “Segmentation fault” without anything else (no stack trace).
Tried it with the balena-engine-v18.9.7-armv6.tar.gz
Any help I can give?

PS: I compiled it with the meta-virtualization package and installed docker-ce (18.09.3-ce) and docker works already, but balenaEngine sadly not :slight_smile:

I have the same pi zero. will have a look as well

1 Like

Just as an information, I also tried the 18.9.7-armv6.tar.gz on the latest raspbian buster release (September 2019, stock from image, no changes or updates) - and the version also gives just out the line “Segmentation fault”.

A test with the 17.12.0-armv6 on raspbian buster on the RPi 1 gives an “Illegal instruction” error.

Hi I was able to reproduce this with the latest 2 builds on the repo. We have heard of issues with the statically linked binaries our build system outputs before and I had done a pre-release of v18.09.10 that is dynamically linked for this very reason…

I will try to get another release for the latest tag out that has dynamic executables for armv5e, armv7hf, aarch64, i386 and amd64 (so all the architectures we support)

Thank you very much! Does this also include armv6l?