Error accessing device: Tunneling socket could not be established

Hi all,

I was following your tutorial here:

And tried to replicate it.
I created the image, booted up the RasPi Zero, aand I get the tunneling socket error:

How do I resolve this?

Check if the service listening on port 80 is throwing any errors or logs containing the status codes. It is possible whatever is listening there might be having an issue. You can also confirm it’s not the issue by trying to reach the service from the network the device is on by using its IP address and port. That would also confirm the issue isn’t the proxy.

When trying to connect to IP, I get the following error:

Quick nmap scan reveals no open ports?
What to do now?

Interestingly enough I am able to connect to the terminal through the Balena interface.

Hi @jm3031, welcome to balena forums!

To be clear, are you deploying the Kerberos project exactly as described in the blog post you linked? Have you done any custom changes to the code? Do you see any further errors or warnings in the device logs?

I’m asking as I don’t see RPi Zero as a supported device for this project. Furthermore, I see an open issue on the code’s repository asking for RPi Zero W support:

Hi @gelbal
After your comments I made a new image to a Raspi 3. Unfortunately I get the same error. Do I need to enable tunneling on my router? That’s not mentioned in the tutorial.

Hi. Could you check the following:

  • The network the device is in respects all our requirements
  • In the device’s dashboard, the main service is running
  • Device’s diagnostics return all green

Ok, I deployed the code in the github which resulted in the main process being present. I think the tutorial needs to be updated as it’s not accurate.


If I read this right - you were able to deploy the app using the GitHub code, but weren’t able to get it to work with the Deploy with Balena button in the blog
Is that right?

Hi JM,

I just clicked the deploy button in the blog post, the application built, and when I added a Pi3b+ the container ‘Main’ downloaded and ran, and the public URL opened OK. So I’m not sure how the tutorial can be far wrong? Could you let me know which part you think isn’t correct?

The only thing I can think of, is perhaps your build didn’t succeed when you used the deploy button? Did you see it say “build succeeded”?