Drive Contains Image message when attempting to select thumb drive


#1

I am using Ubuntu 14.04 LTS and I just installed Etcher 1.4.6. I’m trying to image onto an thumb drive, but I get “Drive Contains Image” and the contents of the box is grayed out.

Any suggestions?

Thank you.

Daryl


#3

Hi there,
Do you see any info in the console opening the DevTools ? What sd card model are you using? We’ll try to replicate the issue so we can debug it.


#4

Please be more specific about the question that you’re asking. I’m not sure what you mean by “…in the console opening the DevTools”.

I’ve tried several different USB drives, including a PNY, and SD and a generic. All behave the same.

Thank you.

Daryl


#5

I literally mean if you open the DevTools (should be ctrl+shift+i on Linux while running Etcher) do you see any error or any useful info in the Console tab?
Also, just so we can exclude it: can you try with a different sdcard/usb reader?
Last but not least: could you provide us with the source image and the target drive path (e.g. /dev/sdX)? You might want to check this issue.

Thanks for the patience


#6

Okay. I’m not a developer, so I’ve never used the DevTools console before. However, I didn’t see any errors when running Etcher.

Also, as I said previously, I’ve tried several different USB drives and all have the same issue, so it’s not the USB drive.

The link that you suggested that I look at is very similar to the issue that I’m having, however, I didn’t see a resolution.

For the source image, I’ve tried several, one that you can try is FreeDOS.img,

The path to my drive is “/dev/sdb”.

Thanks

Daryl


#7

Don’t worry, I’m not a cook so… :smile:
I understand you tried different USB drives, but if you have a different sdcard/usb reader to try with the same usb drives we could verify if that (the reader) is contributing to the failures.
One last question: is the source image on another external drive?

Thanks again


#8

I’m using Etcher on my Ubuntu laptop. There are three USB ports as well as a port for an SD card. I tried multiple USB drives in all three USB ports, all gave me the same error. I tried two SD cards in the SD card reader, but Etcher doesn’t even seem to recognize that port. I also have a portable SD card reader with four different ports on it to accommodate four different types of cards. When I plug it into the laptop, Etcher see’s all four ports and they all have the same error, without any card inserted.

Thank you.

Daryl


#9

Understood.
What about the source image (the one you’re trying to flash from) path? Is it on the computer or on an external drive?


#10

All of the images that I’ve tried where downloaded and reside on the physical machine. Some are ISO images, e.g. Ubuntu installation media, another was the freedos image that I posted previously and a third was a system rescue disk ISO that I downloaded.

Daryl


#11

Did you get it working?
I have the exact same problem (Drive Contains Image) when I try to install Hassbian on my SD-card.
I’ve tried formatting SD as FAT32, EXT4 and without partition at all. Nothing works.


#12

Now I got it working.
I had to use the SD-card reader, in my laptop. Like in your case, Etcher didn’t see my SD-card.
Then I opened settings (top right corner) and checked “Unsafe mode”. Then went back to the Etcher start screen.
Now I could choose my SD-card and etch my image.
BE CAREFUL. You can also choose your system drives.
If you are not sure, don’t do it.


#13

Gibs,

Thank you for the updates. No, I have not gotten it to work, I basically gave up and used a different machine with a different program, one that I knew would work.

I did try the built in SD reader, and I did try the Unsafe Mode, but not both at the same time. I don’t remember why the unsafe mode did not work, but like I said, I didn’t try it when I was using the built in card reader. I’ll have to go back and try it.

I kind of frost me that Etcher stopped responding to my posts. It appears that they’re not trying to resolve the issue.

Daryl


#14

@rosede As mentioned, we’re tracking the issue on GitHub and unfortunately sometimes it overlaps with the forum for issues already tracked, but I’m curious on the solution @GIBS provided so please let us know if it works for you (or if not).
We still have to find the reason behind this and you’ll surely find more details on the GitHub issue once we have more to share, since there we can also link duplicate issues together and reference eachothers


#15

I finally had the opportunity to test in “Unsafe Mode”. If I use a regular Thumb Drive, even in Unsafe Mode, I get the message that the drive contains an image. If I put a card in the on board card reader, the card isn’t even found. I get “No removable drive detected.” However, when I enable the “unsafe mode”, the card is picked up as a system drive. As Gibs said, be careful if using this, because it would be easy to select the wrong drive and wipe out your system drive.

Daryl


#16

Thank you for the precious feedback! I suspect this might be due to internal readers being detected as system drives, along with their children (e.g. drives connected to the built-in readers). A nice bonus would be to try with an external reader, both with and without unsafe mode


#17

Has there been any progress on this issue? It’s been a month since I first posted this issue. I would just like to know if anyone from Balena has been working on this issue.

Thanks

Daryl


#18

We’re actively working on debugging it, you can see some recent progress here as well as the original issue here