Download fails after a few minutes of very slow speed

I am trying to download the pre made image for my RPi3 but am unable to download. This is not an issue with my internet as every other site work with my usual speed of about 1-3MBps.

I have tried with a couple of different browsers a bunch of times but every time it starts off with around 5 - 15 kBps but after getting maybe around 50 MB it simply fails. I have even tried this with my mobile data with a similar result.

Is this a wide issue that many are facing or something I need to look into from my end ?

My region is Mumbai, India if that helps at all.

Hi @bharathyes welcome to the balena forum!

the problem may arise from several factors.
One solution could be to clear the temporary internet files under the History section on your browser and try to download it again. (
In addition, can I ask you if you use any Antivirus software or firewall ?

1 Like


Thanks for the response. Clearing the offline site data helped solve this issue. Wonder why it failed on my mobile though.

Still thanks for the help.

Glad it worked. Let us know if you have any other problems.

The OS launches and I am able to view the dashboard. But now an issue with my RPi3 board:

Is this configurable on the pi to request only smaller tasks?

Or isn’t the pi3 supported as they all have only 1GB of RAM including the plus edition.

@bharathyes unfortunately there is no configuration. if you have a 1gb RAM device and are not receiving any tasks you will simply need to wait for some smaller units to become available.
If you want this part is well explained in the “Announcing Fold for Covid” chapter

1 Like

Ok . Thanks. Will leave it running and check back for any progress :+1: