Does Intel NUC Wifi chip works with resin-wifi-connect?

Resin OS = 2.0.0+rev3
Device type = Resin NUC
resin-wifi-connect v2.0.0

I am trying to use resin-wifi-connect with the Intel NUC Wifi chip Dual Band Wireless-AC 3165. Unfortunately, when starting wifi-connect app, I get the following error:

12.05.17 11:39:18 (+0200) Device type is intel-nuc
12.05.17 11:39:18 (+0200) Using connman.service
12.05.17 11:39:18 (+0200) Error: org.freedesktop.systemd1.NoSuchUnit
12.05.17 11:39:18 (+0200)     at Error (native)

Is this chip supposed to work with resin-wifi-connect ?

:speech_balloon:It looks like it is trying to use connman. resinOS 2.0.0 images are supposed to use NetworkManager. Can you please run systemctl list-unit-files --type=service and post the output here?

UNIT FILE                              STATE   
autovt@.service                        disabled
avahi-daemon.service                   enabled 
bootlogd.service                       masked  
bootlogs.service                       masked  
bootmisc.service                       masked  
checkfs.service                        masked  
checkroot-bootclean.service            masked  
checkroot.service                      masked  
console-getty.service                  disabled
console-shell.service                  disabled
container-getty@.service               static  
cryptdisks-early.service               masked  
cryptdisks.service                     masked  
cups.service                           enabled 
dbus-org.freedesktop.Avahi.service     enabled 
dbus-org.freedesktop.hostname1.service static  
dbus-org.freedesktop.locale1.service   static  
dbus-org.freedesktop.login1.service    static  
dbus-org.freedesktop.machine1.service  static  
dbus-org.freedesktop.timedate1.service static  
dbus.service                           static  
debian-fixup.service                   static  
debug-shell.service                    disabled
display-manager.service                masked  
dnsmasq.service                        enabled 
emergency.service                      static  
fuse.service                           masked  
getty-static.service                   static  
getty@.service                         masked  
halt-local.service                     static  
halt.service                           masked  
hostname.service                       masked  
hwclock-save.service                   enabled 
hwclock.service                        masked  
hwclockfirst.service                   masked  
ifup@.service                          static  
initrd-cleanup.service                 static  
initrd-parse-etc.service               static  
initrd-switch-root.service             static  
initrd-udevadm-cleanup-db.service      static  
killprocs.service                      masked  
kmod-static-nodes.service              static  
kmod.service                           static  
launch.service                         enabled 
module-init-tools.service              static  
motd.service                           masked  
mountall-bootclean.service             masked  
mountall.service                       masked  
mountdevsubfs.service                  masked  
mountkernfs.service                    masked  
mountnfs-bootclean.service             masked  
mountnfs.service                       masked  
procps.service                         static  
quotaon.service                        static  
rc-local.service                       static  
rc.local.service                       static  
reboot.service                         masked  
rescue.service                         static  
rmnologin.service                      masked  
sendsigs.service                       masked  
serial-getty@.service                  disabled
single.service                         masked  
stop-bootlogd-single.service           masked  
stop-bootlogd.service                  masked  
sudo.service                           disabled
systemd-ask-password-console.service   static  
systemd-ask-password-wall.service      static  
systemd-backlight@.service             static  
systemd-binfmt.service                 static  
systemd-fsck-root.service              static  
systemd-fsck@.service                  static  
systemd-halt.service                   static  
systemd-hibernate.service              static  
systemd-hostnamed.service              static  
systemd-hybrid-sleep.service           static  
systemd-initctl.service                static  
systemd-journal-flush.service          static  
systemd-journald.service               static  
systemd-kexec.service                  static  
systemd-localed.service                static  
systemd-logind.service                 masked  
systemd-machined.service               static  
systemd-modules-load.service           static  
systemd-networkd-wait-online.service   disabled
systemd-networkd.service               disabled
systemd-nspawn@.service                disabled
systemd-poweroff.service               static  
systemd-quotacheck.service             static  
systemd-random-seed.service            static  
systemd-readahead-collect.service      disabled
systemd-readahead-done.service         static  
systemd-readahead-drop.service         disabled
systemd-readahead-replay.service       disabled
systemd-reboot.service                 static  
systemd-remount-fs.service             masked  
systemd-resolved.service               disabled
systemd-rfkill@.service                static  
systemd-setup-dgram-qlen.service       static  
systemd-shutdownd.service              static  
systemd-suspend.service                static  
systemd-sysctl.service                 static  
systemd-timedated.service              static  
systemd-timesyncd.service              disabled
systemd-tmpfiles-clean.service         static  
systemd-tmpfiles-setup-dev.service     static  
systemd-tmpfiles-setup.service         static  
systemd-udev-settle.service            static  
systemd-udev-trigger.service           static  
systemd-udevd.service                  static  
systemd-update-utmp-runlevel.service   static  
systemd-update-utmp.service            static  
systemd-user-sessions.service          static  
udev-finish.service                    static  
udev.service                           static  
umountfs.service                       masked  
umountnfs.service                      masked  
umountroot.service                     masked  
urandom.service                        static  
user@.service                          static  
x11-common.service                     masked  

120 unit files listed.

Note that I am running cups but I make sure to stop cups server running on port 80 before starting wifi-connect app

:speech_balloon:Is your device connected? If so, can you provide a link to the device on the resin dashboard?

Yes I just ping you on the private chat with the url of the device

:speech_balloon:Hi Benoit, we fixed one issue, but it is still not working. Can you please leave the device connected so we can investigate further later today ?

Yes no problem I will leave the device connected all day long

Hi @alexis, did you have the time to investigate further regarding this issue ?

:speech_balloon:Hello Benoit. My colleague who was investigating the issue is on leave today. I don’t know if he’s found a solution. We’ll keep you informed.


:speech_balloon:Benoit, the issue is not fixed yet. You can follow the progress here: .

hi @alexis, ok I will follow the progress on the github issue.
Is there any chance resin-wifi-connect might work with conman instead of network manager ? Maybe if I use resin supervisor 1.24.0 ?

@benoitguigal it should work since it’s backwards compatible, but I strongly suggest to use 1.26+ or, even better, 2+ since the fix is coming :slight_smile:

Check the interface names in the terminal using ifconfig (if you’re using the Linux image), then in the Wifi-Connect config file change “wlan0” to the new interface ( mine was ‘wlp58s0’) I have Intel NUC running resin Wifi-Connect flawlessly.

iface: process.env.PORTAL_INTERFACE or ‘wlan0’

change to

iface: process.env.PORTAL_INTERFACE or ‘wlp58s0’

I think you’re right, I had assumed that systemctl list-unit-files --type=service would list NetworkManager but actually this has never been the case. We can probably improve upon the interface selection to make it automatic which should avoid issues like this in the future.

Instead of changing the code you can set an environment variable on the dashboard named PORTAL_INTERFACE, setting the value to wlp58s0 (or whichever interface is returned by ifconfig)

1 Like

Hello @joe, I will try this fix tomorrow and keep you posted. Thank you for the support.

I set PORTAL_INTERFACE to wlp2s0 (which is what ifconfig gives me) on Resin OS 2.0.0+rev3 but I still get the error:

05.06.17 13:54:00 (+0200) Clear is disabled
05.06.17 13:54:00 (+0200) Device type is intel-nuc
05.06.17 13:54:00 (+0200) Using connman.service
05.06.17 13:54:00 (+0200) Error: org.freedesktop.systemd1.NoSuchUnit
05.06.17 13:54:00 (+0200)     at Error (native)
05.06.17 13:54:00 (+0200) Exiting

Did I miss something ?


Did you make any changes to resin-wifi-connect? Can you try increasing the timeout here to around 10 seconds and see if that helps?

Yes indeed I made some changes to resin-wifi-connect. In order to rule out this option, I changed my code to use version 2.0.7 of resin-io/resin-wifi-connect. I increased the timeout to 15, but now I am getting the introspection error:

05.06.17 15:47:31 (+0200) Clear is disabled
05.06.17 15:47:31 (+0200) Device type is intel-nuc
05.06.17 15:47:40 (+0200) { Error: No introspectable
05.06.17 15:47:40 (+0200)     at /usr/src/app/resin-wifi-connect/node_modules/dbus/lib/bus.js:101:15
05.06.17 15:47:40 (+0200)   cause:
05.06.17 15:47:40 (+0200)    Error: No introspectable
05.06.17 15:47:40 (+0200)        at /usr/src/app/resin-wifi-connect/node_modules/dbus/lib/bus.js:101:15,
05.06.17 15:47:40 (+0200)   isOperational: true }
05.06.17 15:47:40 (+0200) Exiting

Please find the link to the project if it might help