Disable bluetooth-audio service

Hello,

I have BalenaSound running on an RPi 2 that does not have bluetooth, When I restart the device, the bluetooth-audio service keeps failing to start and loops. I have to stop it manually via the web portal.

Is there a way to prevent the service from starting by setting a variable (like the variable DISABLE_MULTI_ROOM to prevent the fleet-supervisor and the rest from starting)?

Thank you.

Hi @densmtl, welcome to the forums!

There isn’t currently a way to disable Bluetooth with an environment variable, but that’s a good idea! I encourage you to submit that as a feature request.

In the meantime, there are a couple of things you could experiment with:

  • You could try changing the restart directive in docker-compose.yml from always to never. (See here for more details on your options.)
  • Alternately, you could try commenting out the entire bluetooth-audio stanza in docker-compose.yml.

Give those a try and let us know how they go!

All the best,
Hugh

Hi @saintaardvark,

Thank you for the suggestions. I submitted a feature request and commented out the bluetooth-audio section in the docker file.

Cheers,
Dens

Actually I just saw a PR that would probably solve my issue… :slight_smile: