Didn't show up resin-boot partition

Hi, I am facing a problem that the resin-boot partition didn’t show up on my Windows system once I completed the image burning process by balena Etcher. This is wired that previously it worked good, however, it didn’t show up from today that I burned a new image to fin.

I want to access to the system-connection file to modify the resin-wifi file. But now I cannot access it. I used the latest Etcher version.

Hey there,
Welcome to the forums. I have not been able to reproduce this on Win10 with latest etcher version(1.5.109). Can you please check if Eject on success is enabled in balenaEtcher settings. You would have to plug the sd card again to mount the drive.

hope this helps

resin-boot shows up for me:

@rahul-thakoor Hi, thanks for the reply. I double checked the setting is enabled on Etehcer. However, the resin-boot partition still not shown on my laptop. I directly burned the image to Fin by serial cable.


Hey there,
My bad for misunderstanding - i didn’t notice you mentioned you were flashing the Fin. I have been able to reproduce this and asked my colleague for some additional info. We will get back with more details. Thanks

1 Like

@rahul-thakoor No worries. It seems like it is not the problem of baleanFin itself. I tried with a new Fin and the partition still not shown.

1 Like

Hello @Dexter
I can’t reproduce the issue here.
Which image are you flashing ?
If you do not see the boot partition after flashing, can you try leaving etcher running, un-plug and re-plug the fin, and wait for etcher to finish “initializing” the fin. The boot partition should be detected by windows.

I tried with a new Fin and the partition still not shown.

If this is a new not yet flashed fin, there is no boot partition on it, so this is expected.

According to the screenshot you sent, at the moment of the screenshot the fin has been converted to a mass storage device.
So either windows has a problem detecting the boot partition or there is no boot partition on it.

Try running the windows Disk Management tool to check if the boot partition is present.

Can you please check that automount is enabled in diskpart ?
Open a cmd as administrator, type diskpart and in diskpart, type automount to check if it is enabled and automount enable to enable it.
See http://woshub.com/windows-doesnt-assign-letters-to-external-and-usb-flash-drives/

@zvin Thanks for your solution. It actually works by manually re-set from Disk Management