Did I fry my Pi?

I was experimenting with solar powering a my Fin.
Have a 12v 50w panel12v 10a charge controller12v 6ah battery & the Fin via the Phoenix connector.

It kind of worked, and ran the Fin for a bit. But I also experimented with running:
12v 6ah battery → the Fin via the Phoenix connector

Which I thought would be okay, because I metered the battery as outputting 12.8ish Volts at 3.45 Amps after reading the Fin can handle 6-30V.
But after hearing an odd noise, the Fin is unresponsive to other power inputs, including using the barrel jack off a standard power supply I’ve been using for months.

It seems the Fin is blocking power to the Pi (see pic). And also doing something odd to the RGB LED.

Is the Fin finito? Did I fry my Pi? Did I merely trip the fuse?

Hey @barryjump
the fuse is the white thing on the most left side on the bottom directly between the GPIO header and the HDMI connector. If you have an multimeter, I would like you to unplug/power the Fin and measure the resistance / Ohm of the fuse (see on the picture, the arrow ends would be where to position your test leads).

If it does fail / has infinite resistence, that would mean the fuse is burnt (which would be good, as it might have saved something). But I don’t know about the failure modes of the fin, so maybe the LEDs already say something important to the engineers like @ntzovanis - I just want to chip in as it might help for diagnosis.

If the fuse is burnt you COULD hotwire / jump it with a wire, but be advised that you have no protection anymore on the device and you absolutly cannot use it with your solar setup at this point, only use it with a known good powersupply and only for diagnosis!

Hope that it works out, poor little board :frowning:

Oh and an addition, I oversaw, there is an even more important fuse directly next to barell plug with the same look. Please also measure this. If the fuses are good, they should be around 2 Ohm, if they are broken they will be way higher (or ideally) - infinite :slight_smile:

Maybe @hraftery can help here @barryjump @nmaas87 :slight_smile:

Thanks for the tips @nmaas87. I did measure both those fuses, and they were measuring the expected resistance (that is to say, not infinite).

I didn’t quite trust my multimeter, it was saying about .2, which I’ve read could be merely the leads. I also tested that value against a known good fuse on my Tofu which is a Littlefuse 3.5A (the Fin uses the same but 3A) and it showed roughly the same value.

Unless there are some other tests I can do, I guess that implies I did fry my Pi. :zap:

Poor guy…

Hm I just made a quick test with mine, I have the exact same picture here with a plugged CM3L+
You could try to re-seat the CM3 (but you probably tried this already).
Hm… so it looks really the same, no idea whether the fin would have gotten any damage, but for the moment I would be with you, thinking that the compute module could have been damaged. However, I think they implemented some protection to the GPIO pins and power rails, so… unsure about that. We will have to wait until the start of the week, maybe we get any news.

Sorry, that I cannot help any further at the moment :frowning:

1 Like

Thanks for helping otherwise!

fwiw, I tried to trace the power from barrel jack to fuse, since it seems fuses are not blown. At the barrel I’m reading as expected 12v2.5a. So I must have burned something after the fuse.
Interestingly, it doesnt appear to make a difference where I source power (barrel jack, phoenix, or usb).

Yeah, maybe the CM3 is actually ok, but just the electronic which boots up the CM3 has been burnt.
( I think there is some electronic which powers on everything up in a certain order… )

Yeah, unfort I don’t have any other CM3s to test in the Fin, nor do I have another carrier board to test my CM3. A little stuck :face_with_spiral_eyes:

Sorry, I would offer to test both, but I guess you’re a bit too far away and as I am currently (the last days) already struggling with customs and german DHL I would really advise against sending stuff. Maybe some of our balenaFineros got some additional ideas. Just need for them to wake up :wink:

@nmaas87 I’ll tell you what. If you change your mind on dealing with customs, I’ll send it over to you as is and if you can get it working you can keep it.
I’ve been using the Tofu much more frequently anyway since I wanted to use the CM4s.

1 Like

@barryjump Damn, I am to intrigued by a good mystery… I guess you got me. If Germany is not too expensive to send to :)?

Price is reasonable. I’ll mail it tomorrow :+1:

1 Like

Awesome thank you so much, looking forward to see what I can find out :)!

Hi guys! Heath here from the Fin hardware team. Nice sleuthing so far, and sorry to hear your Fin is sick!

Nothing you’ve described is problematic use - as you rightly point out, the Fin will happily accept your 12V solar panel / battery / charge controller. But it’s not hard to slip and inadvertently cause some mischief. It sounds like you’ve got the cavalry on their way, but in the meantime, some data points:

  • I’m not sure where you measured the 3.45A or the 2.5A. That’s way beyond what the Fin itself would be able to consume and it would certainly go “pop” if allowed to do so.
  • The LED pattern you show (including the dull RGB LED) is the default state of the Fin without a functioning CM3. I think you’re heading in the right direction if the CM3 is where your suspicion lies.
  • The LED pattern would not be possible if the Fin itself were not receiving power effectively, so the fuses are definitely intact.
  • In fact, the circuit that powers the second green LED (3V3) is the same as powers the CM3, so power does not seem to be an issue.
  • For the CM3 to boot you need: a working CM3; and a valid image on the eMMC (ie. the on-board Flash). You might focus on restoring these two aspects to narrow down the issue.
  • The power inputs themselves are pretty hardy, but the 40-pin header behaves much like the equivalent on the Raspberry Pi - it won’t take too much abuse, inadvertent or otherwise.

I wish you luck and look forward to further developments!


Thanks Heath, I will be looking into the situation and I will be sharing my findings :slight_smile:
Maybe we can get that little bugger back to life!

@nmaas87 do you have a spare cm3 lying around? I sent the board with mine, but it may be toast

Thanks for the tips!
I measured the 3.45A coming from the battery terminals itself. So what I fed into the Fin via the phoenix input was 12.8V 3.45A direct from the battery.

Apparently, the right way to do what I was trying to do was to feed PV AND battery into the PV charge controller, then from the charge controller go to the Fin.

I was having some trouble with that setup and went straight from battery → Fin which is when things went poof.

Yeah I got a Fin myself and would use that to diagnose in that case.
Probably will take a close look at the CM3 beforehand.
I am going to get a microscope to my lab end of August, this will probably be one of the first items going beneath it for some close-up shots.

12.8V x 3.45A are a lot of Watts for a small board, could sound like something small shortcircuited, but I will most liklely just plug the fin in without CM3 and just measure the “idle draw” and compare to mine just to be sure there is nothing nasty going on the board before plugging in any other CM3 :slight_smile: (I should make a note to myself to stick to that plan… )

1 Like