Did I fry my Pi?

Yeah, I wasn’t thinking… 43+ watts is actually a lot of juice compared to the typical 5V 2A / 10watt power supply. Whooooops.

what I fed into the Fin via the phoenix input was 12.8V 3.45A direct from the battery

Yeah, something is not right here! There’s no way the Fin would take that much power without sprouting some flames. If you had the PV and charge controller connected, then maybe the 3.45A was actually flowing into the battery from the PV? Anyway, probably not the main issue here but worth double-checking.

Apparently, the right way to do what I was trying to do was to feed PV AND battery into the PV charge controller, then from the charge controller go to the Fin.

Yeah, charge controllers prefer to have the PV and battery all to themselves to manage, so you typically power your load (ie. the Fin) off the charge controller. But still, again, probably not the main issue and just worth double-checking.

I was having some trouble with that setup and went straight from battery → Fin which is when things went poof.

Still can’t see a problem with what you’ve done. Not ideal for the battery and PV, but the Fin shouldn’t care so much.

I did come across another possibility in the meantime - if you disconnect the battery/PV/controller from the Fin and just plug it into a computer via the Micro-USB port and open Etcher, what do you see? Can you flash it? There’s an outside chance the eMMC has been cooked.

I am completely with you, normally this setup (while not ideal) should be not an issue at all.
The balenaFin in question currently left Jamica and is on the way to me for diagnostics.
I guess it will still take some days, but I will report what I can find :slight_smile:

@barryjump The board has finally arrived - and after wrestling it out of the hands of customs with the usual fine and fees - I finally got it in my hands! :smiley:

I got my own/known good balenaFin 1.1.1, plugged out the CM3L+ module and started measuring power draw by using an DPS5005, outputting 12V, with a max current of 1A, “trigger happy” with my thumb on the cut-off switch (not yet needed, but… preparing ;)). Then I measured the power with the CM3.

Then we needed to get to work on the real thing: I popped out the CM3 from @barryjump s poor fin, plugged it in - and saw similar “at rest” current draw. Thats a good thing. Then I popped in the CM3 - the values were all over the bench, but nothing too shocking or exceding the maximum values I saw earlier. But also, as he reported - the LEDs stayed in the “broken” state. Well.

Now was my decision point - what did I trust more? Putting in the “cursed” CM3 module into my fin - or my CM3 into the “cursed” fin? I opted for the second option, putting in my CM3 into the broken fin - powering it on - the power stayed ok, but the LEDs stayed the same. I had a bad feeling. I put in my CM3 into my fin - and was relieved to see it still worked. Ok. It looks like the fin is really toast… so… is there any hope for the CM3? Only one way to find out - putting it into my fin - and nice! It booted!

Ok, the CM3 is ok - the fin is not? Well… I got another idea: I put the “fryed” fin and the “uncursed” CM3 on my PC, started balenaEtcher…

Well, the Sandisk eMMC is fryed! Thats the reason, its the same as with Failing FIN boards and Damaged Fin after power supply failure

So to wrap it up - the CM3 is fine, the balenaFin itself probably too, but the eMMC module on the balenaFin is fryed. I tried multiple rpiboot hacks, mounting it to the pc, trying to low level format it, erasing partitions, rewriting, overwriting with rufus etc - nothing worked sadly. Maybe @hraftery or @ntzovanis have an idea? (I can try to play along with recovery tests. Maybe there is some kind of code that could be run via rpiboot to really low level format the eMMC and getting it working again, other than only trying this via the filesystem mount?)

1 Like

Excellent investigating @nmaas87!
I hope the customs fees/fines did not amount to much. I’m sorry if I incurred you an expense.

Interesting find isolating the problem to the eMMC.

Honestly I didn’t even pay attention to which eMMC module was being used (the Fin’s or the Pi’s). Nor do I recall if my CM3 was the lite version or the one with onboard memory.

I thought my CM3 DID have onboard storage (8gb)… If so, would that mean it’s possible to bypass the ruined Fin eMMC and just use the onboard storage instead?

I wouldnt have a clue how to do that, but in theory it seems possible.

1 Like

Thank you very much - also for providing the Fin! :slight_smile:
It was a nice challenge.
And please don’t worry, you also did pay the postage, so everythings fine :)!
( just for the curious, Germany is normally taking about 6-8 Euros fee for the DHL/customs handling and 19% of the products worth. In the past, this only started after 29 Euros or so, but that has been lifted - for quite some time it did not make sense anymore to buy anything at aliexpress etc because each 1 Euro item would then be costing about 10 Euros, thanks to the import fee + the 19%. Luckily, aliexpress is now working around that with some stuff… :wink: )

All balenaFins do use CM3 Lite Versions, actually, the must use Lite ones.
Reason is that the Fins have onboard eMMC (Sandisk, I think 8, 16 and 32 GB ones) which are hard-soldered. The CM3s “SO-DIMM” interface exposes the SDIO interface needed to communicate with the eMMC, which is then directly connected to the eMMC on the Fin. If the CM3 was not a lite module, you would basically connect two eMMC modules to one port (could also be that the “fat” CM3 do not expose the SDIO interface at all, i don’t know) - but thats the reason why you only can use Lite modules with the Fin. So the 8 GB you saw where there - but on the Fin, not on the CM3. Comes also with the handy idea that if the CM3 where to get damaged, you could just swap it out and continue with your journey - because all data was on the fin :slight_smile:

So in absolut theory - it could/may be possible to cut the specific SDIO traces for the eMMC module on the fin and use a fat CM3 module to get the Fin working again. But again, thats just a theory. Other than the fact that no CM3 or anything is available anywhere apart from the really big companies ;). So, I guess I won’t be trying that ^^‘’‘’.

But maybe we can get @hraftery and @ntzovanis in the game with some updates :slight_smile:

Thanks again, that was a cool opportunity. Its a bit sad that I cannot fully test the Fin, but I guess chances are good that it (with the exception of the eMMC) would still be working - even after the overcurrent. Nice design :slight_smile: !

Oh and another answer:
Basically one could also enable the one time programmable (OTP) bit for booting from USB on the CM3 Lite.
With this, it should try to boot on power on from USB.
This could make the balenaFin available again, but one would need to make all changes necessary in the Raspberry Pi OS installed on the USB stick for taking advantage of all Fin functions.

And this option is NOT reversible, however I read that IF an sdcard / eMMC would be available, it would still boot from this before USB. But thats only what I read.

1 Like

Another idea would be to exchange the eMMC itself:

However, even though it just uses like 10+ signals, it got an like 100+ Ball Grid Array connections. So a little bit of a nightmare to swap out at home. But well, if nothing else helps, maybe its worth a try at some point - just leaving the idea here.

Hey both :slight_smile: The 32MB issue is a known problem for the balenaFin and we are willing to exchange the device under RMA. I’ve looped in the relevant people in charge of starting this process and they will be in touch shortly! Thanks for investigating this @nmaas87 :slight_smile:

1 Like

Awesome! Thanks for the update :slight_smile: I think its a testament to how balena handles issues - they work with the customers and try to help :slight_smile: - reliable companies and good support are the best, good job :slight_smile:

Dear Nico,

This is Stefanos from balena. Please find attached the RMA form we need you to fill out to process your request. Once we have the document signed, we will proceed to schedule a DHL device pickup and start investigating the problem.

Please don’t hesitate to contact us for any further needs.

Best regards,

Stefanos Sakellariou
Balena Ltd - RMA Form- Nico Maas.pdf (414.8 KB)

@stefsak that’s very generous of you guys. @nmaas87 let me know how it works out!

Please let me know if there is any cost involved in the return. Don’t want to impose more fees on you.

1 Like

Thank you :slight_smile:
balena did provide a free return ticket and the board has already arrived on saturday at balena.
I am currently waiting for the new board to get send out - but balena managed in the past to work out the customs issues very well, so I think there should be no bad surprises :slight_smile:
But thank you very much :slight_smile:

1 Like

Let us know when you receive the newest fin!

Let’s stay connected @barryjump @nmaas87 :slight_smile:

1 Like

Roger, wilco :slight_smile:

1 Like

@mpous Just going through my thread list and I have not forgotten the topic, but I am still waiting for getting a new Fin or the repaired one back, have not received any update since I mailed it in.

1 Like

Heya, yesterday I got a lovely package from athens - with some awesome content:

The fin somewhat has “accidentally” even doubled its capacity from 8 to 16 GB and is working perfectly <3

Thank you very much @stefsak and @mpous <3! one happy CM3 back from the dead-ish :slight_smile:

Great @nmaas87 glad it arrived well. Enjoy :slight_smile:

1 Like

Thank you so very much :slight_smile: