Device saying "Offline" but still getting logs

Hi, I pushed out a balena update and for some reason my device is showing offline, but I’m still getting logs from it. image

I’ve have tried doing a “hard restart” of the device by turning the plug off and then on again but it hasn’t sorted it. What can I do to fix this?

In general this means that the device is not connected to the VPN.
Do you know if there might be restrictions on the device’s network?
Do you have an online device on the same network?

Hi, it has been working fine all week on the same network. I changed my node-red flows and did a balena push and a reboot and it was showing offline.

I was trying to test my node-red flow that handles data logging on a USB, and if the USB isn’t connected it saves the data on the SD card. I got the USB part working, but it was when I tried to data log to the SD that the device went offline. I’ve since managed to revert back so that it only writes to the USB incase this was the issue. My device has now just came back online so I think it was an issue with my flow.

This seems unrelated, might this have been a coincidence?

It may have been, however, the flow was using a couple of “file-lister” nodes that appeared to cause the node-red to constantly restart if they couldnt see the file they were looking for - this caused a different pi4 to crash that was running standard raspbian so I’ve taken them out the flow and it seems to have solved this issue too.

Great, please ping us if the device appears offline again.