Creating a Project with a VM Help

Hello everyone,

I do not have a Raspberry Pi or other such small computer so I want to try to set up a balenaCloud project with a VM. I followed this tutorial: How to create VMware or VirtualBox virtual machine from Balena app image
However, I encountered an issue here and there and was not able to successfully set up the project in the end. One issue I encountered was that the docker the tutorial requested I used was not compatible with my Windows 10 version (Windows 10 Home) so I tried using docker desktop instead.
This was also my first time setting up a virtual machine so I’m not 100% sure I got that part right but it seemed like I successfully flashed the balena intel nuc image onto the VM. However, the tutorial stated that the VM should appear as a device in my balena project and that it should restart itself after a bit, but neither of those things happened.
Lastly, following the removal of the vmdk from the VM as requested as one of the last steps of the tutorial, I launched the VM again and I am not sure that it yielded the results it should have.

I was wondering if anyone might be able to offer any tips/advice or another tutorial I could try for the setup? I would really appreciate any help that could be offered.

Hi @myarmolinsky, what’s the last thing the screen shows after it’s done provisioning?

I’d be curious to see if there’s an error message of some sort. Also check your network settings - if the VM can’t react Balena’s servers then it won’t show up on your dashboard. You’ll want to have the network setup as NAT, or you could try Bridged as well.


The network I have chosen in my VM is NAT. There was no error message from what I could tell aside from an error message when trying to complete the optional pre-load step in the tutorial. It seemed to complete the process and then it asked me for a login and password (from some further online research I found that for login I should enter “root” and then I can just press enter for password). When I run the VM now, here is how it looks:

Nothing more is shown and this screen is considerably different from the entire process when running the VM for the first time.
Also, as mentioned I tried removing the vmdk after the first-time setup appeared to be complete as the tutorial requested, but oddly (contrary to the tutorial’s warning), re-adding it and and running the VM again does not re-flash/restart the setup.

This is actually my first time ever setting up a virtual machine as well so please forgive me if I misunderstand something or have a knowledge gap somewhere, but I would be happy to learn and I appreciate any help that can be offered!

That looks very odd to me. It shouldn’t be prompting you to continue… it should be showing Balena related logging. You mentioned that you tried preloading the image. That’s a pretty advanced way to set this up… try loading just the image that you download from Balena. That way you’ll know that the preload isn’t doing something odd (which it often can do, as you mentioned with a username/password, which is very strange).

Let me know what the screen looks like after provisioning from a base image with no modifications.

I followed the tutorial again but without the preloading. I got a welcome to balenaOS message and then it started to do its thing. There were a lot of "OK"s but I also got these warnings/errors during the process:

Some points that I noticed differed from the tutorial:

  • I did not see the device appear in my application dashboard at any time as the tutorial says it should.
  • The process seems to have stopped at the following point after [OK] Started Update UTMP about System Runlevel Changes
  • The device did not power off when “done”

I would also like to note that I have not yet followed that last step: “Once it is powered off, go to the virtual machine settings and remove the Balena VMDK disk, otherwise you will re-flash a new image every time you boot. This is the equivalent of removing the USB stick from the device. You should only have one virtual disk attached to Controller: SATA .” because following it is what resulted in starting the VM showing that shell screen I previously posted a screenshot of. Would you please mind confirming whether this step is required?

The VM isn’t shutting down because it’s not completing the provisioning process properly. Same goes for the device showing up on the dashboard… and that’s ultimately what has to happen for this to work.

I downloaded VirtualBox and tested it and I was able to reproduce the same issue. I also saw the first screenshot you provided after the provisioning failed and I attempted to use the same VM to retry the provisioning process.

My guess was that there was a change in BalenaOS that is causing the failure, so I downloaded a v2.48 image (rather than the latest v2.68) and tried again. It seemed to get much further, but never shut down and the device never appeared on the dashboard.

I’m not sure what the issue would be without spending more time on it. I can tell you that VMWare does work with the v2.48 version of the OS, so you might try downloading an evaluation version and seeing if that works.

I see. Thank you for all your help with this, I appreciate all the time you’ve invested into trying to help me debug this. I might try with VMWare like you said. If I make progress or figure anything out, I’ll be sure to reply to this thread.

Just to add my 2 cents - I use this method of running an Intel x86 image on my virtualbox running on Linux. I was able to do this by following the guide No hardware? Use VirtualBox to simulate a device for balenaCloud!

One difference is that I use Bridged Adapter in my network settings. The device shows up fine in my dashboard.

Interesting, thank you! I’ll give that a try.