Create a fleet of centrally-managed Bluetooth low-energy(ble) beacons with ble-lighthouse and balena

Please use the thread below to discuss the related blog post:

Hi, created 1 device using the deploy with balena button. Device starts but I don’t see de bleutooth device. When device starts the following message appears:
28.02.22 09:27:37 (+0100) main true
28.02.22 09:27:37 (+0100) main URL
28.02.22 09:27:37 (+0100) main
28.02.22 09:27:37 (+0100) main 01234567890123456789012345678901
28.02.22 09:27:37 (+0100) main
28.02.22 09:27:37 (+0100) main beacon broadcast stop!
28.02.22 09:27:37 (+0100) main LE set advertise enable on hci0 returned status 12

What am I doing wrong?

Hello @nl-limburg , can you share a bit more details about what kind of device you’re using? Internal or external BT radio and if you made any changes to ENV variables ? thanks!

Im using a raspberry pi zero W 2 board with on-board bluetooth.
Did not change any ENV vars.

@nl-limburg I just got a couple of RPI zero W 2 boards yesterday, will try this tomorrow and see how it goes.

@nl-limburg , I found the issue and resolved it. Basically there were a couple of things going on

1- hostname was not set in /etc/hosts file of the container so I modified my script to add it there

2- The ENV variable to enable advertising should be TRUE but because of some parsing policy it was treated as boolean true(lower-case) causing the script to not work correctly, i converted it into string and tested it with Rpi zero 2 W and everything is working now. Please re-deploy the fleet using hub, DWB or balena push and it should work.

I tested it, and seems to be also
working now on RPI0 2 W