Could not detect project type: Resolution could not be performed

When pushing the Balena Dash app i get the folowing error :

[Info] Starting build for BelenaDash, user jeffrey2
[Info] Dashboard link:
[Error] Could not detect project type: Resolution could not be performed
[Error] Not deploying release.

anyone ? help ?

Hi @DW_Jeff, first of all welcome to balena community : )

Checking the earlier forum posts I see that another user had this issue and he resolved it by updating the docker compose file to match the folder names:

Let us know if that doesn’t help.

Then we would need more info from you to continue troubleshooting.

Hi Gelbal,

i’m totally new to this so maybe i’m forgetting something…

I tried to follow the instructions, figured out that i needed to install git and balenacloud on my desktop to push the git repo to the raspberry. I think I understood it all untill i reached the " Deploying code" chapter. So i installed git for windows and downloaded the app and installed the cli tools and then i tried to push it to the raspberry, after that i got the error.

Is there any other noob manual or did i forget something ? Maybe i’ll write a manual after i’m done… to help other “idiots” :wink:

FYI i did not put a DockerFile into my local repo… i have the idea thats the step i am missing…

Got it working by running the balena push command in the downloaded git folder… then it worked…

Got to see the unicorn… So installation worked…

Logs give a lot of error messages… and the Device Variable doesnt work so still not functional…

scheduler /bin/sh: /usr/src/ not found
wpe standard_init_linux.go:195: exec user process caused “no such file or directory”

I installed it with windows 10 and i saw that there were problems… ( Docker file does not COPY files in subdirectories correctly when pushing to a local Balena device from Windows 10 )

anyone with a solution ?

We are performing some tests with the project and will be getting back to you as soon as we have results.

Hey @DW_Jeff,

Two things, which device are you running this project on?
Have you entered all the environment variables for the project?


In my case I had named my file dockerfile.template instead of capital D, Dockerfile.template :frowning: