Release failure

Hi there! I am a beginner user of balenaClouds. I would like to create a multi-room system to listen to music. My father started this project he added the devices then asked me to continue. I saw that the next step is to create releases. So I spent a few hours to learn how to do it. I downloaded and installed the balena CLI and the ‘balena-node-hello-world’ zip file from GitHub. I used the Terminal to login in to the balena. When I sent the command ‘push’ it started to build but then it sent two error messages.
[Error] Could not detect project type: Service main: package.json: engines.node must be specified
[Error] Not deploying release.
Could you tell me what did I do wrong? What should I change.
Note: now on the website there is a green tick for the release but there is no green tick for the devices. I can still see the devices on the website

Hi @Nutella02,
Can you clarify the version of balena-cli that you are using, and the exact command that you are using to push the new release?
I just cloned the balena-node-hello-world sample repository and was able to balena push balena-node-hello-world-test on a new application that I just created.
Please also confirm that you are indeed running balena push while being in the root directory of that repository.

Kind regards,

I’m using v12.7.4 windows x64. I’m not sure if I’m at the root directory.

You should be able to have the windows console print the current directory by typing cd and pressing enter.
If that doesn’t match the root folder of your project (where the Dockerfile.template is in the balena-node-hello-world sample project), then you should use cd and provide the path of that folder, like:

cd C:\users\<username>\your\path\to\balena-node-hello-world

For example, if you have that folder on your desktop, you can navigate there by:

cd C:\Users\<username>\Desktop\balena-node-hello-world

Can you provide some extra context about how you run balena push and the exact command that you are using?

I used the Terminal. I logged in then I reached the root of the repository. After that I used ‘balena push ApplicationName’.
It started to upload but after 6 or 7 seconds it stopped. These are the error messages:
‘[Error] Could not detect project type: Service main: package.json: engines.node must be specified
[Error] Not deploying release.
Remote build failed’
On the website I can see that there were releases failure. All of my releases run on 0 devices but there are 2 devices in this application. Should I re add the devices?

Before executing balena push, could you enter the dir command and make sure you can see a Dockerfile.template file in the list that dir outputs?

Yes I did that but the problem was still on!

Update: After a day off I started to think about the problem. I realized that I should see the ‘Dockerfile.template’. I saw this file but as ‘dockerfile.template’. For some reason it wasn’t a capital ‘d’. So I renamed the file as it should be. After that it worked perfectly and now I have my release. Thanks for your help and patient, it’s awesome to be in a community like this. Have a nice day!

Hey there,
Glad it worked. Thanks for the feedback