Connection Raspberry Pi 3 wifi to channel 13

Hi, I installed Hassio (based on resinio and docker) without problems using ethernet-LAN. I want to use the wifi interface to connect to a separate wifi network (this has my home-devices).
I have setup the wifi config as described here , this works when the wifi broadcast is on channel 11. When I move my router to channel 13 (I am in the Netherlands), the wifi connection does not happen.
I have adapted the config.json as follows:
“persistentLogging”: false,
“uuid”: “…removed original value for this post…”,
“deviceApiKey”: “…removed original value for this post…”,
“country”: “NL”
This does not seem to have any effect.

To solve this I logged in to the core-system, remounted / to rw and introduced /etc/modprobe.d/cfg80211.conf with line "options cfg80211 ieee80211_regdom=NL"
Now it works but this is probably not the official way…

Would you mind trying "country":"GB" as an experiment and letting us know how that goes, not suggesting it as a solution, but it will tell us a bit more about whether the problem is that “NL” is not supported or whether channel 13 is not supported.

Ok, I tried “country”: “GB” but that has not effect on the wifi channels.
I considered my solution with the cfg80211 parameters, and realized that you could maybe pass that as kernel parameters. So I tried that, appending cfg80211.ieee80211_regdom=GB (or NL) to the end of the line in the cmdline.txt file works…
Apparently the parameter in config.json does not influence the wifi region…
Let me know if I should try something else, for now I am happy with the modification of the comdline.txt file.

Hi all - Was there an official resolution to this topic. I have issues connecting to channel 13 and nothing seems to work. With bare raspbian I can configure country to GB for instance and make a successful connection, but not with Balena.

Hi, I followed up on the other forums topic you opened here: RPi 3 not connecting to WiFi channel 13