Connect to wifi

Hey @alpo that does sound odd, can you also provide the output of ifconfig -a and the content of your config.txt for reference?

This is the output of ifconfig -a:

pi@raspberrypi:~ $ ifconfig -a
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.5.212 netmask 255.255.255.0 broadcast 192.168.5.255
inet6 fe80::1b1b:5e2f:a030:d14f prefixlen 64 scopeid 0x20
ether b8:27:eb:d6:ef:21 txqueuelen 1000 (Ethernet)
RX packets 34773 bytes 3830093 (3.6 MiB)
RX errors 0 dropped 2067 overruns 0 frame 0
TX packets 14343 bytes 11553376 (11.0 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 25 bytes 1484 (1.4 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 25 bytes 1484 (1.4 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

As you can see I’m connected with wired ethernet but I can’t see WiFi.

And is is my config.txt:

For more options and information see

http://rpf.io/configtxt

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=800
#framebuffer_height=600

uncomment if hdmi display is not detected and composite is being output

hdmi_force_hotplug=1

Force a specific HDMI mode (800x600 60Hz)

hdmi_group=2
hdmi_mode=9
hdmi_ignore_edid=0xa5000080

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

dtparam=i2c_arm=on
#dtparam=i2s=on
dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on
dtoverlay=balena-fin-updated
dtoverlay=i2c-rtc,ds1307

Thank you in advance.

Hey @AlPo and @markusk , I’m currently investigating this issue. It appears as though the wlan driver we supply with our raspbian image is being removed upon apt-get upgrade.

I’m currently working towards a solution for this and will report back as I get more information.

Thanks!

Thank you @bucknalla.
Only as a patch while you’re looking for a permanent solution, is there a way to manually load the drivers in question?

@bucknalla, do you have some news?

Hi @AlPo,

It looks like it has to do with our CI doing automated releases of the fin Raspbian image - I’m checking with the OS team to see if we can package the driver as standalone for the time being so we can get you up and running. I’ll keep checking in here as this develops!

Thanks for your patience!

I just also want to say that we are in the same boat. We needed to reinstall several of our balenaFins due to the wlan driver disappearing after an update. So yea, a workaround (packaged standalone driver) would be much appreciated at this point!

@bucknalla Do you have an update on this issue? If its going to take some time to get a corrected version of Raspbian out, can you point us in the right direction of the wireless drivers? This is turning into a real issue for us.

Thanks!!

@mad.dove and @Jgilbert,

The devices team have resolved this driver issue and published a deb package which should resolve your wifi issues for your existing devices. The raspbian image is currently being tested and once verified will be uploaded to the balena fin raspbian repo.

You can install the sd8887-mrvl package with dpkg -i sd8887-mrvl_0.0.4-1_all.deb

Let me know how you get on with this and thanks again for your patience!

@bucknalla Thanks! I downloaded the two files “sd8887-mrvl_0.0.4-1_all.deb” and “sd8887-mrvl_0.0.4-1_all.deb.asc”, and ran the dpkg command above. I received the error that its not a valid Debian package.

Can you double check that the package is correct?

Thanks

John

@Jgilbert I’ve tried it on my own machine and it appears to be fine and install correctly; could you please share the command you ran from your terminal?

Thanks!

I did this in the same directory as the files. I am pretty sure its user error, so any tips are appreciated.

Does it need to be run from a certain place?

Thanks

@Jgilbert that should be correct; could you please share the error message?

Thanks!

@bucknalla I’m sorry I can’t get a screenshot or direct quote here, but this is what I am seeing:

sudo dpkg -i sd8887-mrvl_0.0.4-1_all.deb dpkg-deb: error: 'sd8887-mrvl_0.0.4-1_all.deb ' is not a Debian format archive dpkg: error processing archive sd8887-mrvl_0.0.4-1_all.deb (--install): dpkg-deb --control subprocess returned error exit status 2 Errors were encountered while processing: sd8887-mrvl_0.0.4-1_all.deb

Thoughts?

John

@Jgilbert Could you please run this dpkg-deb --info sd8887-mrvl_0.0.4-1_all.deb and let me know what you get as the output?

@bucknalla I ran the above command, and received the error stating that its not a Debian format archive.

I also changed to a different directory (still in home/Downloads), re-downloaded the two files (with Curl), and ran the original sudo dpkg commands. I received the same results.

I performed a “sudo apt-get update” and install, and reran the dpkg command, and received the same results.

Do I need to download any other files from https://bintray.com/balenaos/raspbian/sd8887-mrvl/0.0.4-1#files/pool%2Fmain%2Fs%2Fsd8887-mrvl to make this work?

If you’re going to have the Raspbian update out the door soon (this week), I can wait for it. Although, frankly, my inability to install a software package really bothers me.

John

@Jgilbert No worries, it’s puzzling me too - you could try downloading it with apt-get install sd8887-mrvl - I’ve been advised it should always be available there now too. Let me know if that works and which version of sd8887 it installs?

Thanks!

To add some more visibility to what is happening behind the scenes, we’ve got the patched Raspbian image in staging now and are testing the build. We’re aware that there are some further tweaks that are required - Problems flashing co-processor on balenaFin V1.1 (via. Raspbian) and are additionally working on these issues. We’re aiming to push the wlan fix on monday and will notify here when it’s up.

Again, thanks everyone for your patience whilst we fix this!

@bucknalla Running

sudo apt-get install sd8887-mrvl

results in

sd8887-mrvl is already the newest version (0.0.2-1)

I did

sudo apt-get remove --purge sd8887-mrvl

to remove the driver in order to reinstall.

Running

sudo apt-get install sd8887-mrvl

results in

Unable to locate package sd88887-mrvl

OK - no problem. I downloaded the files above, and suddenly, the dpkg command worked. Rebooted.

nmcli shows

wlan0: unavailable
“Marvell Wi-Fi”
wifi (wlan_sdio), (MAC Address), hw, mtu 1500

I have to step away, but next steps will be to turn on that interface.

More to follow…

John

@bucknalla OK - we are up and running.

I needed a couple of additional commands:

sudo systemctl start wpa_supplicant.service
nmcli device wifi connect (SSID) password (PSK)

Currently connected to both wired and wireless connections.

Please let us know when the Raspbian image is available.

Thanks!

John