Connect to wifi

wifi

#1

Hi,

I used a vanilla pi image on the fin, and it seems that I cant access the wifi module. Is there documentation on how I can connect to it?

Thanks


#4

Hi,

Is there a reason why you want to use a RPi image instead of a Fin image?

You can download from the dashboard a Fin image and select in NETWORK CONNECTION field the WiFi + Ethernet option. You will type there the WiFi credentials that will be added to your image.

After flashing this image, your board will automatically connect to WiFi and the dashboard.

Regards!


#5

We are migrating our system from Pi3 to Balena and we are checking if it can be ported easily to the new board. So far all the peripherals are working except for the wifi module.


#6

Hi @pao,

To take advantage of all the hardware features of the Fin board you will need to use an OS image tailored for Fin.

Is there a reason why you want to flash the RPi3 images on the Fin?

Because you could flash the Fin boards with their specific images and then push the same application that you had on RPis on the Fin board.

Regards!


#7

So the BalenaOS runs on top of the raspbian image and can be disabled? Do i need a monitor and keyboard to set this up?


#8

Hey @pao

I think I misunderstood what you need.

Let’s clarify a little bit.

You are running Raspbian on RPi3 and you want to run Raspbian on Fin also?

BalenaOS doesn’t sit on top of Raspbian and it’s a separate OS.


#9

Hi there, we are targeting to maintain a raspbian version already configured for the Fin, that you can find more about here: https://www.balena.io/fin/docs/developers/

Also, you could still just enable the balena-fin mainline device tree overlay ( in config.txt: dtoverlay=balena-fin ) in a standard raspbian and have access to all the hw specifics, whith a note on the wifi/BT driver that would be the opensource one instead of the Marvell propetary that in our experience has proven to be more reliable.

What we do on our Fin-configured rasbian image from the vanilla one:

  • add dtoverlay=balena-fin to /boot/config.txt
  • disable opensource wifi/bt driver
  • install Marvell wifi/bt driver and corresponding fw binary for the chip

#13

@curcuz Thanks! that did the trick.


#14

@pao awesome, glad to hear!