command child-writer.js fails


I am trying to flash HomeAssistantOS to an Odroid N2 with an eMMC (Red) 124 GB storage. I have tried flashing straight to the eMMC, and flashing to the Odroid with the eMMC attached to it.

When flashing directly to the eMMC, it usually doesn’t show up as a drive, but when it does and I run Etcher, I get this error:
erroutput.txt (734.2 KB)
You may notice the error is just child-writer.js

When flashing to the Odroid while the eMMC is connected, it shows up as a drive as long as I have run

ums /dev/mmcblk0

in the Odroid shell. Then I get the same error.

Since the first line of the error is that it won’t run etcher, I guessed that Windows Defender might be preventing me from flashing, so I turned it off, tried again as admin, and the error is the same for both methods.
I think the issue is with this file somehow, my security settings are still blocking something or I am missing some dependency/setup, but I don’t see a clear route to go from here.

The eMMC is brand new and I am on Windows 11

Hello, it looks like possibly there is an issue reaching the URL of the file to flash. What URL are you using? If you paste it into a browser, does it download the file? If so, can you try flashing the downloaded file rather than using a URL? (Assuming you are following the steps here: ODROID - Home Assistant)

Facing a same problem reagarding to command child-writer but its working. Thanks

Thanks @alanb128 !
That is indeed where I was following instruction; that is my bad as I meant to include that with my error description but forgot to.

I have tried your suggestion of downloading it first instead of flashing from URL and I am finally able to flash. However my flashing fails at 100%, although it appears to have finished. A quick read of the error gives me the impression that the error is irrelevant to the OS itself, so I will connect it to a screen when I am home and see if it works and get back. Until then, here is a copy of the output, with the error being the last 2 lines of the output

erroutput2.txt (2.4 KB)